测试赛D - The War(有控制范围的贪心)

D - The War
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
Submit   Status

Description

A war had broken out because a sheep from your kingdom ate some grasses which belong to your neighboring kingdom. The counselor of your kingdom had to get prepared for this war. There are N (1 <= N <= 2500) unarmed soldier in your kingdom and there are M (1 <= M <= 40000) weapons in your arsenal. Each weapon has a weight W (1 <= W <= 1000), and for soldier i, he can only arm the weapon whose weight is between minWi and maxWi ( 1 <= minWi <= maxWi <= 1000). More armed soldier means higher success rate of this war, so the counselor wants to know the maximal armed soldier he can get, can you help him to win this war?

Input

There multiple test cases. The first line of each case are two integers N, M. Then the following N lines, each line contain two integers minWi, maxWi for each soldier. Next M lines, each line contain one integer W represents the weight of each weapon.

Output

For each case, output one integer represents the maximal number of armed soldier you can get.

Sample Input

3 3
1 5
3 7
5 10
4
8
9
2 2
5 10
10 20
4
21

Sample Output

2
0

贪心的问题,人可以使用的有一些范围,武器有重量,唯一要解决的问题就是在一个人的控制范围内包含另一个人的,这种情况要让范围小的先找

y有小到大,如果y相同时x由小到大。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node{
    int x , y ;
} p[2600];
int q[1200] ;
bool cmp(node a,node b)
{
    return a.y < b.y || ( a.y == b.y && a.x < b.x ) ;
}
int main()
{
    int i , j , n , m ;
    while(scanf("%d %d", &n, &m) !=EOF )
    {
        memset(q,0,sizeof(q));
        for(i = 0 ; i < n ; i++)
            scanf("%d %d", &p[i].x, &p[i].y);
        while(m--)
        {
            scanf("%d", &i);
            q[i]++ ;
        }
        m = 0 ;
        sort(p,p+n,cmp);
        for(i = 0 ; i < n ; i++)
        {
            int l = p[i].x , r = p[i].y ;
            for(j = l ; j <= r ; j++)
                if( q[j] )
            {
                q[j]--;
                m++ ;
                break;
            }
        }
        printf("%d\n", m);
    }
    return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值