hdu2795Billboard(线段树,找第一个大于w的点)

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10676    Accepted Submission(s): 4728


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
线段树问题,给出h*w的广告版,每一个广告是1*w的,给出m个广告,要每张广告尽量在上层尽量靠左,输出它所在的高度,如果放不下,就输出-1
这里的问题就是h给的很大,但是 一共只有m个广告,所以即使是一条广告占一条,那么也就只需要m的高度,多余的高度没有用,如果m的高度的不能放下m条广告,那么即使h再高,也放不下,所以n应该是m和h的小值,一段存储下它所控制的区间的最大值,只要最大值大于广告wi,那么第i条广告就可以放到这个区间内。先判断左子树,左子树不合适后判断右子树,除非是当前的wi大于整段的最大值,否则一定可以放到广告版内,注意,在放入一个广告之后,修改所有的父节点的最大值。
 
 
 
#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;
#define maxn 300000
#define lmin 1
#define rmax n
#define lson l,(l+r)/2,rt<<1
#define rson (r+l)/2+1,r,rt<<1|1
#define root lmin,rmax,1
#define now l,r,rt
#define int_now int l,int r,int rt
int cl[maxn<<2] , k[maxn<<2] , top ;
void push_up(int_now)
{
    cl[rt] = max( cl[rt<<1], cl[rt<<1|1] ) ;
}
void creat(int w,int_now)
{
    if( l != r )
    {
        creat(w,lson);
        creat(w,rson);
        push_up(now);
    }
    else
    {
        cl[rt] = w ;
        k[rt] = ++top ;
    }
}
int update(int w,int_now)
{
    int ans ;
    if( cl[rt] < w )
        return -1 ;
    if( l == r && cl[rt] >= w )
    {
        cl[rt] -= w ;
        return k[rt] ;
    }
    else
    {
        if( cl[rt<<1] >= w )
            ans = update(w,lson);
        else
            ans = update(w,rson);
        push_up(now);
        return ans;
    }
}
int main()
{
    int i , n , w , m ;
    while(scanf("%d %d %d", &n, &w, &m)!=EOF)
    {
        top = 0 ;
        n = min(n,m);
        creat(w,root);
        while(m--)
        {
            scanf("%d", &w);
            printf("%d\n", update(w,root));
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值