hdu3549--Flow Problem(初识最大流)

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 7870    Accepted Submission(s): 3664


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
  
  
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
  
  
Case 1: 1 Case 2: 2
 
第一次接触最大流,水题练手,使用了EK的方法,这个题不需要考虑建图,直接使用模板
 
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
#define maxn 2100
#define INF 0x3f3f3f3f
struct edge{
    int v , w ;
    int next ;
} p[maxn];
int head[maxn] , cnt , vis[maxn] , pre[maxn];
queue <int> q ;
void add(int u,int v,int w)
{
    p[cnt].v = v ; p[cnt].w = w ;
    p[cnt].next = head[u] ; head[u] = cnt++ ;
    p[cnt].v = u ; p[cnt].w = 0 ;
    p[cnt].next = head[v] ; head[v] = cnt++ ;
}
int bfs(int s,int t)
{
    int u , v , i , min1 = INF ;
    while( !q.empty() )
        q.pop() ;
    memset(vis,0,sizeof(vis));
    vis[s] = 1 ;
    q.push(s) ;
    while(!q.empty())
    {
        u = q.front() ;
        q.pop();
        for(i = head[u] ; i != -1 ; i = p[i].next )
        {
            v = p[i].v ;
            if( !vis[v] && p[i].w )
            {
                vis[v] = 1 ;
                min1 = min(min1,p[i].w);
                pre[v] = i ;
                q.push(v) ;
            }
        }
    }
    if(vis[t])
        return min1 ;
    return -1 ;
}
int main()
{
    int tt , t , n , m , i , u , v , w , max_flow;
    scanf("%d", &t);
    for(tt = 1 ; tt <= t ; tt++)
    {
        cnt = 0 ; max_flow = 0 ;
        memset(head,-1,sizeof(head));
        scanf("%d %d", &n, &m);
        while(m--)
        {
            scanf("%d %d %d", &u, &v, &w);
            add(u,v,w);
        }
        memset(pre,-1,sizeof(pre));
        while(1)
        {
            int k = bfs(1,n);
            if(k == -1)
                break;
            max_flow += k ;
            for(i = pre[n] ; i != -1 ; i = pre[ p[ i^1 ].v ] )
            {
                p[i].w -= k ;
                p[i^1].w += k ;
            }
        }
        printf("Case %d: %d\n", tt, max_flow);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值