poj1459--Power Network(最大流EK、)

Power Network
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 23114 Accepted: 12103

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.
 
题意很纠结,给出了n个点,其中np个节点是供电站,nc个节点是消耗,出给m条电线,每条线给出了(u,v)w代表u节点到v节点最多输送w,然后输入np个点(u)w,代表节点u是供电站,提供w的电量,nc个点(u)w节点u是消耗,消耗w。问最多消耗多少。
源点连接所有的供电站,每条线的容量是供电站的最大供电量,消耗点都连接汇点,容量是最大的消耗量,求最短路
使用EK的话,如果用邻接矩阵才能过,使用前向星会超时
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
#define INF 0x3f3f3f3f
#define maxn 110
int p[maxn][maxn] , pre[maxn] , vis[maxn];
queue <int> q ;
void add(int u,int v,int w)
{
    p[u][v] += w ;
}
int bfs(int s,int t,int n)
{
    int u , v , i , min1 = INF ;
    memset(vis,0,sizeof(vis));
    vis[s] = 1 ;
    while( !q.empty() )
        q.pop();
    q.push(s) ;
    while( !q.empty() )
    {
        u = q.front();
        q.pop();
        if(u == t)
            break;
        for(i = 0 ; i <= n ; i++)
        {
            if( !vis[i] && p[u][i] )
            {
                pre[i] = u ;
                vis[i] = 1 ;
                q.push(i) ;
            }
        }
    }
    if( vis[t] )
    {
        for(i = t ; pre[i] != -1 ; i = pre[i])
            if( p[pre[i]][i] < min1 )
                min1 = p[ pre[i] ][i] ;
        return min1 ;
    }
    return -1 ;
}
int main()
{
    int n , np , nc , m , u , v , w , max_flow , i , j ;
    char str[10] ;
    while(scanf("%d %d %d %d", &n, &np, &nc, &m)!=EOF)
    {
        max_flow = 0 ;
        memset(p,0,sizeof(p)) ;
        while(m--)
        {
            scanf("%s", str);
            sscanf(str,"(%d,%d)%d", &u, &v, &w);
            add(u,v,w);
        }
        while(np--)
        {
            scanf("%s", str);
            sscanf(str,"(%d)%d", &v, &w);
            add(n,v,w);
        }
        while(nc--)
        {
            scanf("%s", str);
            sscanf(str,"(%d)%d", &u, &w);
            add(u,n+1,w);
        }
        memset(pre,-1,sizeof(pre));
        while(1)
        {
            int k = bfs(n,n+1,n+1);
            if(k == -1)
                break;
            max_flow += k ;
            j = n+1 ;
            for(i = pre[n+1] ; i != -1 ; i = pre[i])
            {
                p[i][j] -= k ;
                p[j][i] += k ;
                j = i ;
            }
        }
        printf("%d\n", max_flow);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值