poj1523--C - SPF(连通分量,求割点)

C - SPF
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit   Status

 

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible.  

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.  

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist.  

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

给出无向边,输入到0结束,问割点是谁,并且求出割点将图分成几个连通分量

割点的求法就是tarjan,在求出割点后用并查集找出将图分成几块,注意对于根,如果根只有一个子树,那么根不是割点,但用tarjan判断也会判断成割点,所以要特判根节点

所以,如果割点找出的分块数是1,不用输出。

输出是坑,要求每个空两个格,一个案例空一行

 

 

#include <cstdio>
#include <cstring>
#include <stack>
#include <algorithm>
using namespace std;
#define maxn 1200
struct node
{
    int u , v ;
    int next ;
} edge[1000000] ;
int head[maxn] , cnt , vis[1000000] ;
int dnf[maxn] , low[maxn] , time ;
int ans[maxn] ;
int c[maxn] , n ;
stack <int> sta;
void init()
{
    memset(head,-1,sizeof(head));
    memset(vis,0,sizeof(vis));
    memset(dnf,0,sizeof(dnf));
    memset(low,0,sizeof(low));
    memset(ans,0,sizeof(ans));
    cnt = time = n = 0 ;
}
void add(int u,int v)
{
    edge[cnt].u = u ;
    edge[cnt].v = v ;
    edge[cnt].next = head[u] ;
    head[u] = cnt++ ;
    edge[cnt].u = v ;
    edge[cnt].v = u ;
    edge[cnt].next = head[v] ;
    head[v] = cnt++ ;
}
int find1(int x)
{
    int r , k , l ;
    r = x ;
    while( r != c[r] )
        r = c[r] ;
    k = x ;
    while( k != r )
    {
        l = c[k] ; c[k] = r ; k = l ;
    }
    return r ;
}
int f(int s)
{
    int i , j , u , v , num[maxn] , sum = 0 ;
    memset(num,0,sizeof(num));
    for(i = 1 ; i <= n ; i++)
        c[i] = i ;
    for(i = 1 ; i <= n ; i++)
    {
        for(j = head[i] ; j != -1 ; j = edge[j].next)
        {
            if( edge[j].u == s || edge[j].v == s )
                continue ;
            u = find1( edge[j].u ) ;
            v = find1( edge[j].v ) ;
            if(u != v)
                c[u] = v ;
        }
    }
    for(i = 1 ; i <= n ; i++)
    {
        if( head[i] != -1 && i != s )
        {
            num[ find1(i) ]++ ;
        }
    }
    for(i = 1 ; i <= n ; i++)
        if( num[i] )
            sum++ ;
    return sum ;
}
void tarjan(int u)
{
    dnf[u] = low[u] = ++time ;
    int v, i ;
    for(i = head[u] ; i != -1 ; i = edge[i].next)
    {
        if( vis[i] ) continue ;
        vis[i] = vis[i^1] = 1 ;
        v = edge[i].v ;
        if( !dnf[v] )
        {
            sta.push(i);
            tarjan(v);
            low[u] = min( low[u],low[v] );
            if( low[v] >= dnf[u] && !ans[u] )
            {
                ans[u] = f(u);
            }
        }
        else if( dnf[v] < dnf[u] )
            low[u] = min( low[u],dnf[v] );
    }
}
int main()
{
    int u , v , temp = 0 , i;
    while(scanf("%d", &u) && u)
    {
        temp++ ;
        init();
        scanf("%d", &v);
        add(u,v);
        n = max(n,u);
        n = max(n,v);
        while(scanf("%d", &u) && u)
        {
            scanf("%d", &v);
            add(u,v);
            n = max(n,u);
            n = max(n,v);
        }
        tarjan(1);
        int flag = 0 ;
        printf("Network #%d\n", temp);
        for(i = 1 ; i <= n ; i++)
            if( ans[i] > 1 )
            {
                printf("  SPF node %d leaves %d subnets\n", i, ans[i]);
                flag = 1 ;
            }
        if( !flag )
            printf("  No SPF nodes\n\n");
        else
            printf("\n");
    }
    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值