poj2503--Babelfish(字典树一水)

Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 32988 Accepted: 14189

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

Source

Waterloo local 2001.09.22
输入一个字典,前面一个单词和后面的单词映射,问给出的单词有没有对应的,有输出,没有,输出eh
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node{
    int flag ;
    node *next[27] ;
} *head;
node *getnode()
{
    node *p = new node ;
    int i ;
    for(i = 0 ; i < 27 ; i++)
        p->next[i] = NULL ;
    p->flag = -1 ;
    return p ;
}
void gettree(node *p,char *s,int m)
{
    int i , k , l = strlen(s);
    for(i = 0 ; i < l ; i++)
    {
        k = s[i] - 'a' ;
        if( p->next[k] == NULL )
            p->next[k] = getnode();
        p = p->next[k] ;
    }
    p->flag = m ;
}
int f(node *p,char *s)
{
    int i , k , l = strlen(s) ;
    for(i = 0 ; i < l ; i++)
    {
        k = s[i] - 'a' ;
        if( p->next[k] == NULL )
            return -1 ;
        p = p->next[k] ;
    }
    return p->flag;
}
char s1[110000][12] , s2[110000][12] , s[30] ;
int main()
{
    int i = 0 , j , l , k ;
    head = getnode();
    while(1)
    {
        gets(s);
        if(s[0] == '\0')
            break;
        sscanf(s,"%s %s", s1[i], s2[i]);
        gettree(head,s2[i],i);
        i++ ;
    }
    while(gets(s)!=NULL)
    {
        if(s[0] == '\0')
            break;
        k = f(head,s);
        if(k == -1)
            printf("eh\n");
        else
            printf("%s\n", s1[k]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值