poj2828--Buy Tickets(线段树+详解)

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 13618 Accepted: 6802

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i(1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

Source

POJ Monthly--2006.05.28, Zhu, Zeyuan

 

题目大意,插队的问题,每个案例给出n,代表有n个插队的,每个给出p,v,意思是代号为v的人插在了第p个人的后面,问最后的队伍的排列?

题目中一开始整个队列是空的,也就是说如果输入i,j:代表代号为j的人插在了第i个人的后面,也就是说在他之前一定有了i个人,而他的位置是i+1。

所以由后向前推到,每个遇到的都是确定位置的,最后的人选定的位置不会改变,同样因为是倒叙输入,在第i个人后插队,也就是说他的前面一定要留下i个空格。

经过这样的转化后就可以用线段树解决,lazy中存了代号,cl数组中存了每个节点中包含的空格的数目。

 

 

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define maxn 210000
#define lmin 1
#define rmax n
#define root lmin,rmax,1
#define lson l,(l+r)/2,rt<<1
#define rson (l+r)/2+1,r,rt<<1|1
#define now l,r,rt
#define int_now int l,int r,int rt

struct node
{
    int a , b ;
} p[maxn];
int cl[maxn<<2] , lazy[maxn<<2] ;
int n , i ;
void push_up(int_now)
{
    if( l != r )
        cl[rt] = cl[rt<<1] + cl[rt<<1|1] ;
}
void creat(int_now)
{
    cl[rt] = lazy[rt] = 0 ;
    if( l != r )
    {
        creat(lson);
        creat(rson);
        push_up(now);
    }
    else
        cl[rt] = 1 ;
    return ;
}
void update(int a,int k,int_now)
{
    if( l == r && cl[rt] == 1 )
    {
        cl[rt] = 0 ;
        lazy[rt] = k ;
    }
    else
    {
        if( a <= cl[rt<<1] )
            update(a,k,lson);
        else
            update(a-cl[rt<<1],k,rson);
        push_up(now);
    }
    return ;
}
void pre(int_now)
{
    if( l == r )
    {
        if(n == 1)
            printf("%d\n", lazy[rt]);
        else
            printf("%d ", lazy[rt]);
        n-- ;
    }
    else
    {
        pre(lson);
        pre(rson);
    }
    return ;
}
int main()
{
    while( scanf("%d", &n)!=EOF )
    {
        for(i = 0 ; i < n ; i++)
        {
            scanf("%d %d", &p[i].a, &p[i].b);
            p[i].a++ ;
        }
        creat(root);
        for(i = n - 1 ; i >= 0 ; i--)
        {
            update(p[i].a,p[i].b,root);
        }
        pre(root);
    }
    return 0;
}


 

  • 2
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值