Number Sequence

Description

A number sequence is defined as follows: 

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7. 

Given A, B, and n, you are to calculate the value of f(n). 
 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed. 
 

Output

For each test case, print the value of f(n) on a single line. 
 

Sample Input

       
       
1 1 3 1 2 10 0 0 0
 

Sample Output

       
       
2 5
 


找循环,因为是对七取余,所以结果也就是0  1  2  3  4  5  6        7种,最少其次,即  7*7 = 49 种,循环节不一定以  1   1  开头。

#include <stdio.h>
#include <string.h>
#define pi 3.1415927

int sz[60];
int main()
{
    int a,b,n,i,j,xc,xj,bj;

    while(~scanf("%d%d%d",&a,&b,&n))
    {
        bj = 0;
        sz[0] = 1;
        sz[1] = 1;
        sz[2] = 1;
        if(a == 0 && b == 0 && n == 0)
            break;
        for(i = 3; i<=n && bj == 0; i++)
        {
            sz[i] =  (a * sz[i - 1] + b * sz[i - 2]) % 7;
            for(j = 2; j<i; j++)
            {
                if(sz[j] == sz[i] && sz[j-1] == sz[i-1])
                {
                    xc = j;
                    xj = i;
                    bj = 1;
                    break;
                }
            }
        }
        if(bj == 1)
            printf("%d\n",sz[xc + (n - xj) % (xj - xc)]);
        else
            printf("%d\n",sz[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值