POJ模拟——Parencodings

Parencodings
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
 
   
 
   
 
   
 
   
输入的数字代表有一个“)”,在其之前有这些数字个“(”,求每次遇到“)”时,最大可以组成多少个“()”
 
   
 
   
这是正确的代码,用下标记录的:
#include <stdio.h>
#include <string.h>
#include <math.h>
#include<algorithm>
using namespace std;

int jl[30];
char zhan[30];
char kh[30];

int main()
{
    int n,m,i,j,k,low,top;
    scanf("%d",&n);
    while(n--)
    {
        memset(kh,0,sizeof(kh));
        memset(jl,0,sizeof(jl));
        k = -1;
        scanf("%d",&m);
        for(i = 1;i<=m;i++)
        {
            scanf("%d",&jl[i]);
            for(j = 1;j<=jl[i]-jl[i-1];j++)
            {
                kh[++k] = '(';
            }
            kh[++k] = ')';
        }
        kh[++k]='\0';
        int bj = 0;
        for(int x = 0;x < k;x++)
        {
            if(kh[x] == ')')
            {
                top = 1;low = 0;
                for(int y = x - 1;y>=0;y--)
                {
                    if(kh[y] == '(')
                        low++;
                    else if(kh[y] == ')')
                        top++;
                    if(top == low)
                        break;
                }
                if(bj == 0)
                    printf("%d",top);
                else
                    printf(" %d",top);
                bj++;
            }
        }
        printf("\n");
    }
    return 0;
}

以下代码使用指针和栈结合写出的,能够正确运行,但不知道为什么叫上去不对
#include <stdio.h>
#include <string.h>
#include <math.h>
#include<algorithm>
using namespace std;

int jl[30];
char zhan[30];
char kh[30];

int main()
{
    int n,m,i,j,k,low,top;
    scanf("%d",&n);
    while(n--)
    {
        memset(kh,0,sizeof(kh));
        memset(jl,0,sizeof(jl));
        k = -1;
        scanf("%d",&m);
        for(i = 1;i<=m;i++)
        {
            scanf("%d",&jl[i]);
            for(j = 1;j<=jl[i]-jl[i-1];j++)
            {
                kh[++k] = '(';
            }
            kh[++k] = ')';
        }
        kh[++k]='\0';
        printf("%s\n",kh);
        char *p = kh;
        low = top = -1;
        int bj = 0;
        while(*p != '\0')
        {
            if(*p == ')')
            {
                int num = 0;
                char *pt = p;
                zhan[++top] = *pt;
                pt--;
                while(*pt != '\0' && top != low)
                {
                    if(*pt == '(')
                    {
                        num++;
                        top--;
                    }
                    else if(*pt == ')')
                    {
                        zhan[++top] = *pt;
                    }
                    pt--;
                }
                if(bj == 0)
                    printf("%d",num);
                else
                    printf(" %d",num);
                bj++;
            }
            p++;
        }
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值