Shortest Prefixes

Shortest Prefixes
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona
 
   
这道题目挺好玩!!!
输入一些字符串,以文件结束为结束,求在这些字符串中,每一串相对于其他字符串的最大前缀。
思路:
每输入一串字符串,就用字典树整理出来,每个字母出现一次,相应的次数就加1,最后对于每一个字符串进行字典树查询,查到的第一个字母出现次数为1的字母和之前的字母就是这个字符串的最大前缀。
 
   

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>

using namespace std;

struct node
{
    int flag;
    struct node *next[27];
}*head,*p;
char sz[1009][30];

node *newnode()
{
    int i;
    struct node *q;
    q = (struct node *) malloc (sizeof(struct node));
    q->flag = 0;
    for(i = 1; i <= 26; i++)
    {
        q->next[i] = NULL;
    }
    return q;
}

int jianshu(int i,node *p)
{
    int l,j,k;
    l = strlen(sz[i]);
    for(k = 0; k < l; k++)
    {
        j = sz[i][k] - 'a' + 1;
        if(p->next[j] == NULL)
        {
            p->next[j] = newnode();
             p = p->next[j];
             p->flag++;
        }
        else
        {
             p = p->next[j];
             p->flag++;
        }
    }
}

void cha(int j,node *p)
{
    int l,m,k;

    l = strlen(sz[j]);
    printf("%s ",sz[j]);
    for(m = 0; m < l; m++)
    {
        k = sz[j][m] - 'a' + 1;
        p = p->next[k];
        if(p->flag != 1)
            printf("%c",sz[j][m]);
        else if(p->flag == 1)
        {
            printf("%c",sz[j][m]);
            break;
        }
    }
    printf("\n");
}

int main()
{
    head = newnode();
    int i = 1,j,k;
    while(scanf("%s",sz[i]) != EOF)
    {
        jianshu(i,head);
        i++;
    }
    for(j = 1; j < i; j++)
    {
        cha(j,head);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值