Borg Maze——BFS+最小生成树

Borg Maze
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11
 
   
对于这道题目,真心是无奈啊!!!
题意:
给你一个地图,‘#’不可走,其它的地方都可以走,‘A’和‘S’看作城市,求这些城市相连的最短距离。
 思路;
很明显,就是最小生成树,可是每两个城市之间的距离没有啊,这就需要用BFS一一计算出来,建立一个二维数组,存储任意两点间的距离。但是只有'A'和'S'两种点,还需要将他们转换成数字一遍查找,这时,有一个问题出现了,50*50的地图,可以生成2500个这样的点,字符型的数最多只有250,不够用啊,要怎么办呢,看代码吧,在WA了N此后,我决定不再撞南墙了,一另外一种方法改变这种状态:



#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
#define N 150
#define MAXIN 1000000

using namespace std;

int mapp[N][N],ds[N],n,s,bh[10000];
int b[N];

int h,w;
char ch[55][55];
int vis[55][55];
struct node
{
    int x,y;
    int step;
};
int dirx[] = {-1,1,0,0};
int diry[] = {0,0,-1,1};

void bfs(int x,int y)
{
    struct node a,b;
    int i,k1,k2;
    memset(vis,0,sizeof(vis));
    vis[x][y] = 1;
    a.x = x;
    a.y = y;
    a.step = 0;
    queue<node>Q;
    k1 = x * w + y;
    Q.push(a);
    while(!Q.empty())
    {
        a = Q.front();
        Q.pop();
        for(i = 0; i < 4; i++)
        {
            b.x = a.x + dirx[i];
            b.y = a.y + diry[i];
            if(b.x>=0 && b.y>=0 && b.x<h && b.y<w && ch[b.x][b.y]!='#' && vis[b.x][b.y] == 0)
            {
                vis[b.x][b.y] = 1;
                b.step = a.step + 1;
                if(ch[b.x][b.y] == 'A' || ch[b.x][b.y] == 'S')
                {
                    k2 = b.x * w + b.y;
                    mapp[bh[k1]][bh[k2]] = b.step;
                    mapp[bh[k2]][bh[k1]] = b.step;
                }
                Q.push(b);
            }
        }
    }
}

void Prim()
{
    int i,k;
    memset(b,0,sizeof(b));
    b[s]=1;
    int Min,sum=0;
    int t=n;
    while(--t)
    {
        Min=10000;
        for(i=1; i<=n; i++)
            if(!b[i]&&Min>ds[i])
            {
                Min=ds[i];
                k=i;
            }
        if(Min==10000)
            break;
        b[k]=1;
        sum+=Min;
        for(i=1; i<=n; i++)
            if(!b[i]&&mapp[k][i]<ds[i])
                ds[i]=mapp[k][i];
    }
    printf("%d\n",sum);
}


int main()
{
    int T;
    char xiaochu[1000];
    int i,j,k;
    scanf("%d",&T);
    while(T--)
    {
        n = 0;
        scanf("%d%d",&w,&h);
        gets(xiaochu);
        for(i = 0; i < h; i++)
        {
            gets(ch[i]);
            for(j = 0; j < w; j++)
            {
                if(ch[i][j] == 'A' || ch[i][j] == 'S')
                {
                    k = i* w + j;
                    bh[k] = ++n;
                    if(ch[i][j] == 'S')
                        s = n;
                }
            }
        }
        for(i = 1; i <= n; i++)
        {
            for(j = 1; j <= n; j++)
            {
                mapp[i][j] = MAXIN;
            }
        }
        for(i = 0; i < h; i++)
        {
            for(j = 0; j < w; j++)
            {
                if(ch[i][j] == 'A' || ch[i][j] == 'S')
                    bfs(i,j);
            }
        }
        for(i = 1; i <= n; i++)
            ds[i] = mapp[s][i];
            Prim();
    }
    return 0;
}



 
   
 
  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值