Surprising Strings——MAP

Surprising Strings
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.
 
   
题意:分别以不同的间隔由两个字母组成的字母对是否重复,如果有重复的,输出NOT surprising.,否则,输出surprising.

解析:如果字符串长度小于等于2,则一定不会有重复的。如果大于2,借助map<string,int>,标记字母对是否出现过。

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <stdlib.h>
#include <math.h>
#include <ctype.h>
#include <queue>
#include <map>
#include<algorithm>

using namespace std;


int main()
{
    char sz[100];
    int i,j,k,l;
    while(gets(sz))
    {
        if(sz[0] == '*')
            break;
        l = strlen(sz);
        if(l <= 2)
        {
            printf("%s is surprising.\n",sz);
            continue;
        }
        int flag;
        for(i = 0;i <= l-2;i++)
        {
            flag = 0;
            map<string,int>q;
            for(j = 0;j < l-i;j++)
            {
                char ch[3] = {sz[j],sz[j+i+1],'\0'};//将字母对组成字符串的形式
                if(q[ch] == 0)//如果该字母对没有出现过,则标记为出现
                {
                    q[ch] = 1;
                }
                else//否则,说明之前已经出现过了,得出结论,不会使人惊讶,跳出循环即可
                {
                    flag = 1;
                    break;
                }
            }
            if(flag == 1)
                break;
        }
        if(flag == 1)
            printf("%s is NOT surprising.\n",sz);
        else
            printf("%s is surprising.\n",sz);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值