HDU1505——City Game(扫描线)

City Game
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees, factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units. The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N. The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input

The first line of the input file contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units, separated by a blank space. The symbols used are:
R – reserved unit 
F – free unit
In the end of each area description there is a separating line.

Output

For each data set in the input file print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output

45
0
 
   
第一次接触扫描线,学了一个上午才把这个根本就不需要前期准备,直接用扫描线的题目解决。。。。。。
题意:
给出一个地图,R代表墙,F代表空地,求空地的最大面积
R F F F F R 
F F F R R F
R R R F F F
F F F F F F
R R R F F R
这个地图,最大矩形由1*6 或是2*3 或是3*2组成,输出来的结果就是18。
 
   
#include <iostream>
#include <cstdio>
#include <algorithm>
#define maxin 1000

using namespace std;

int mapp[maxin][maxin],up[maxin][maxin],lft[maxin][maxin],rght[maxin][maxin];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int m,n,i,j;
        scanf("%d%d",&m,&n);
        for(i = 0; i < m; i++)//输入地图
        {
            for(j = 0; j < n; j++)
            {
                char ch = getchar();
                while(ch != 'F' && ch != 'R')
                    ch = getchar();
                if(ch == 'F')
                    mapp[i][j] = 0;
                else
                    mapp[i][j] = 1;
            }
        }
        int ans = 0;//记录最大面积
        for(i = 0; i < m; i++)
        {
            int lo = -1,ro = n;//lo表示当前行最靠右的墙的位置,ro表示当前行的最靠左的墙的位置
            for(j = 0; j < n; j++)//遍历左边的墙
            {
                if(mapp[i][j] == 1)//1代表遇到了墙
                {
                    up[i][j] = lft[i][j] = 0;//因为已经遇到了一堵墙,所以不能组成一块空地,所以令高度清零
                    lo = j;//记录最靠右的墙的位置
                }
                else//在没有墙的情况下
                {
                    if(i == 0)//第一行的值
                    {
                        up[i][j] = 1;//空地的宽初始化为1
                        lft[i][j] = lo+1;//记录在该点下,距离其最远的不是墙的位置
                    }
                    else//如果不是第一行
                    {
                        up[i][j] = up[i-1][j]+1;//空地的宽由上一行的宽加1构成
                        lft[i][j] = max(lft[i-1][j],lo+1);//既然是记录下距离最近的墙的最远的距离,当然是求最大值。
                    }
                }
            }
            for(j = n-1; j >= 0; j--)//从右边开始遍历,记录右边的墙以及每块空地的右闭区间
            {
                if(mapp[i][j] == 1)
                {
                    rght[i][j] = n;
                    ro = j;
                }
                else
                {
                    if(i == 0)
                    rght[i][j] = ro-1;
                    else
                        rght[i][j] = min(rght[i-1][j],ro-1);
                    ans = max(ans,up[i][j]*(rght[i][j]-lft[i][j]+1));//面积为两片强的距离(长)*宽
                    //计算在该位置下,其所在的空地的面积,并和之前的相比取最大值
                }
            }
        }
        printf("%d\n",ans*3);
    }
    return 0;
}


1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 、4下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合;、下载 4使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合;、 4下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.m或d论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 、1资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值