strstr函数

串结构练习——字符串匹配
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

  给定两个字符串string1和string2,判断string2是否为string1的子串。
 

Input

 输入包含多组数据,每组测试数据包含两行,第一行代表string1,第二行代表string2,string1和string2中保证不出现空格。
 

Output

 对于每组输入数据,若string2是string1的子串,则输出"YES",否则输出"NO"。
 

Sample Input

abc
a
123456
45
abc
ddd

Sample Output

YES
YES
NO
 
   

函数原型:extern char *strstr(char *haystack, char *needle)

参数说明:haystack为一个源字符串的指针,needle为一个目的字符串的指针。          所在库名:#include <string.h>    函数功能:从字符串haystack中寻找needle第一次出现的位置,但是该函数不比较结束符NULL。    返回说明:返回指向第一次出现needle位置的指针,如果没找到则返回NULL。

#include<stdio.h>  
#include<algorithm>  
#include<string.h>  
#include<iostream>  
#define N 999  
using namespace std;  
int main()  
{  
    char str1[N],str2[N],str3[N];  
    while(cin>>str1>>str2)  
    {  
        if(strstr(str1,str2))  
        printf("YES\n");  
        else printf("NO\n");  
    }  
    return 0;  
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值