POJ 2976 Dropping tests (01分数规划+二分)

Dropping tests
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7360 Accepted: 2558

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

题目大意:给n个数对a[i],b[i],然后去掉k个之后,使剩下的n-k组,sum(a[i])/sum(b[i])最大。

01分数规划问题。

先来看一下什么是01分数规划:令a=(a1,a2,a3,...,an),b=(b1,b2,b3,...,bn),x=(x1,x2,x3,...,xn)都是n维整数向量,求a*x/b*x的最大值或最小值,其中x[i]只能取0或1,也就是求(a1*x1+a2*x2+a3*x3+...+an*xn)/(b1*x1+b2*x2+b3*x3+...+bn*xn),且xi={0,1},的最值,x取01的意思就是:如果xi取1,那么ai,bi就会能同时取得;如果xi取0,ai和bi就是同时不取。这样就满足题目说的对应的ai和bi要么都取,要么都不取。
向量x的存在,是我们解题的突破口,题目说n个里取掉k个,其实就是去n-k对,那么我们就可以指定xi=1,来取ai,bi,那么怎么取才最大呢,所以我们要想策略,接着往下看。

假设我们要求这个式子的最大值,那么如何解这个式子呢?   假设这个式子的最大值,也就是最优解为val,即val=max(a*x/b*x)。 设置这样一个子问题:q(L)=a*x-b*x*L,然后我们分配向量x,来使q(L)取得最大值max注意:这个式子不是一下能算出来的,因为a,b,x都是向量,如果向量是m维的,那么我们应该把算出来的m个数求和。
这时q(L)的最大值max就分两种情况来看:
①max<0 ,即a*x-b*x*L<0 ----> a*x<b*x*L  ----> (a*x)/(b*x) <L ,那么无论怎么分配x都没法到达L值,即val<L,所以解要比L小,我们应该适当减小L的值再试。
②max>=0 即val>=L,  且进一步还知道,当取到L=val时,有a*x-b*x*L=0,所以此时解要>=L,那么我们应当增大L的值再试。

上面两种情况的最后蓝色部分已经可以看出,我们可以二分L。

说到这,上面说的要想策略,策略就是:分配x,使q(L)=a*x-b*x*L最大,我们需要求出n个t[i]=a[i]-b[i]*L,然后对t排序,取前n-k组最大的即可。

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int maxn=1000+10;
int a[maxn],b[maxn],n,k;
double t[maxn];

int cmp(double x,double y){
	return x>y;
}

bool C(double x){		//这里的x就是上面分析的L
	int i;
	double sum=0;
	for(i=0;i<n;i++)
		t[i]=a[i]-x*b[i];
	sort(t,t+n,cmp);
	for(i=0;i<n-k;i++)		//策略就是取前n-k组最大的求和,sum表示q(L)的最大值
		sum+=t[i];
	return sum>0;
}

int main()
{
	int i,j;
	while(scanf("%d%d",&n,&k)){
		if(n==0 && k==0) break;
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(i=0;i<n;i++)
			scanf("%d",&b[i]);
		double l=0,r=1;
		for(i=0;i<20;i++){		//注意精度
			double m=(l+r)/2;
			if(C(m))
				l=m;
			else
				r=m;
		}
		printf("%d\n",(int)(l*100+0.5));
	}
	return 0;
}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值