J - MANAGER(2.4.5)

J - MANAGER(2.4.5)
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

One of the programming paradigm in parallel processing is the producer/consumer paradigm that can be implemented using a system with a "manager" process and several "client" processes. The clients can be producers, consumers, etc. The manager keeps a trace of client processes. Each process is identified by its cost that is a strictly positive integer in the range 1 .. 10000. The number of processes with the same cost cannot exceed 10000. The queue is managed according to three types of requests, as follows: 
  • a x - add to the queue the process with the cost x; 
  • r - remove a process, if possible, from the queue according to the current manager policy; 
  • p i - enforce the policy i of the manager, where i is 1 or 2. The default manager policy is 1 
  • e - ends the list of requests. 

There are two manager policies: 
  • 1 - remove the minimum cost process 
  • 2 - remove the maximum cost process 

The manager will print the cost of a removed process only if the ordinal number of the removed process is in the removal list. 

Your job is to write a program that simulates the manager process. 

Input

The input is from the standard input. Each data set in the input has the following format: 
  • the maximum cost of the processes 
  • the length of the removal list 
  • the removal list - the list of ordinal numbers of the removed processes that will be displayed; for example 1 4 means that the cost of the first and fourth removed processes will be displayed 
  • the list of requests each on a separate line. 

Each data set ends with an e request. The data sets are separated by empty lines.

Output

The program prints on standard output the cost of each process that is removed, provided that the ordinal number of the remove request is in the list and the queue is not empty at that moment. If the queue is empty the program prints -1. The results are printed on separate lines. An empty line separates the results of different data sets. 

An example is given in the following:

Sample Input

5
2
1 3
a 2
a 3
r
a 4
p 2
r
a 5
r
e

Sample Output

2
5
//数据集合之间有空行。
#include<iostream>
#include<algorithm>
using namespace std;
int a[10000],i,b[10000],c,j,k,p,j1,mn,qq[100];
	int n,m;
	char s;
void shanchu()
{
	n++;
   sort(a,a+k);
   if(p==1)
	  {
	   for(i=0;i<j1;i++)
		   if(n==b[i])
		   {qq[mn]=a[0];mn++;break;}
	   a[0]=999999;
   }
   else
   {
	   for(i=k-1;i>=0;i--)
		   if(a[i]!=999999)
		   {
			   m=a[i];
			   a[i]=999999;
			   break;
		   }
	   for(i=0;i<j1;i++)
		   if(n==b[i])
		   {qq[mn]=m;mn++;}

   }
}
int main()
{
	
   while(cin>>n&&n)
   {
	   mn=0;
	   n=0;
	   cin>>j1;
	   j=0;
	   i=j1;
		   k=0;
		   p=1;
	   while(i--)
		   cin>>b[i];
	   while(cin>>s)
	   {
		   
		   if(s=='e')
			   break;
		   switch(s)
		   {
		  // case 'e':break;
		   case 'a':cin>>a[k],k++;break;
		   case 'r':shanchu();break;
		   case 'p':cin>>p;break;
		   }
	   }
	   for(i=0;i<j1;i++)
		   cout<<qq[i]<<endl;



   }
   cout<<endl;
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值