P - FatMouse and Cheese HDU 1078 ( 记忆化搜索 )


P - FatMouse and Cheese
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status Practice HDU 1078

Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.


Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.


Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.


Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1



Sample Output

37


#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=222;
const int inf=999999999;
int a[maxn][maxn];
int vis[maxn][maxn];
int n,k;
int dx[]={1,-1,0,0};
int dy[]={0,0,-1,1};
int dfs(int x,int y){//从当前点出发能够到达的最大的和
    if(vis[x][y])return vis[x][y];
    int ans=0;
    for(int j=1;j<=k;j++)
    for(int i=0;i<4;i++){
        int xx=j*dx[i]+x;
        int yy=j*dy[i]+y;
        if(xx>=0&&xx<n&&yy>=0&&yy<n&&a[x][y]<a[xx][yy]){
           ans=max(ans,dfs(xx,yy));
        }
    }
    vis[x][y]=ans+a[x][y];
    return vis[x][y];
}

int main()
{
    while(scanf("%d%d",&n,&k)&&(n!=-1&&k!=-1)){
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                scanf("%d",&a[i][j]);
            }
        }
        memset(vis,0,sizeof(vis));
        printf("%d\n",dfs(0,0));
    }
    return 0;
}










  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值