POJ 2342 (树形DP)

Anniversary party
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3863 Accepted: 2172

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5
题意:有一个大学的庆典晚会,想邀请一些在大学任职的人来参加,每个人有自己的搞笑值,但是现在遇到一个问题就是如果两个人之间有直接的上下级关系,那么他们中只能有一个来参加,求请来一部分人之后,搞笑值的最大是多少


思路:树形DP,在整个树上跑一遍dfs,设dp[s][0]表示不取s时以s为跟节点的子树的最大搞笑值,dp[s][1]表示取s时以s为跟节点的子树的最大搞笑值,则状态转移方程为:
          dp[s][0] += max(dp[u][0], dp[u][1]);
        dp[s][1] += dp[u][0];
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAXN 6010
using namespace std;
int dp[MAXN][2], rat[MAXN];
int vis[MAXN], head[MAXN];
typedef struct{
    int to, next;
}Edge;
Edge edge[MAXN];
void addedge(int u, int v, int k){
    edge[k].to = v;
    edge[k].next = head[u];
    head[u] = k;
}
void dfs(int s){
   dp[s][0] = 0;
   dp[s][1] = rat[s];
   for(int i = head[s];~i;i = edge[i].next){
       int u = edge[i].to;
       dfs(u);
       dp[s][0] += max(dp[u][0], dp[u][1]);
       dp[s][1] += dp[u][0];
   }
}
int main(){
    int n, u, v, father;
    freopen("in.c", "r", stdin);
    while(~scanf("%d", &n)){
        memset(vis, 0, sizeof(vis));
        memset(head, -1, sizeof(head));
        for(int i = 1;i <= n;i ++) scanf("%d", rat+i);
        for(int i = 1;i <= n-1;i ++){
            scanf("%d%d", &u, &v);
            addedge(v, u, i);
            vis[u] = 1;
        }
        scanf("%d%d", &u, &v);
        for(int i = 1;i <= n;i ++){
            if(!vis[i]){
                father = i;
                break;
            }
        }
        dfs(father);
        printf("%d\n", max(dp[father][0], dp[father][1]));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值