浅谈ISIS协议

版权声明:若需转载,请附上链接。 https://blog.csdn.net/u013181216/article/details/46611399

一.ISIS背景:

IS-IS(中间系统到中间系统),ISO无连接网络协议(CLNP)设计的路由选择协议,IS-IS协议主要应用在一些ISP和政府网络。

ISO发展IS-IS协议的时间和IAB(Internet体系结构委员会)发展OSPF协议的时间基本相同,算法一致。

二.ISIS基本特征:

OSI层次:网络层,基于链路层运行。

协议类型:链路状态路由协议。

有类/无类:无类。

IGP/EGP:IGP。

管理距离:ISO协议栈 --- 110 , TCP/IP协议栈 --- 115。

度量值:

wide(宽度量)---默认

接口度量默认全部为10,最大值2^24-1;总路径开销上限为2^32-1。

narrow(窄度量)---默认

接口开销不管带宽多少全部为10,最大值为63;总路径开销上限1023。

delay可选的,反映了子网的传输。

expense可选的,反映子网的成本开销。

error可选的,反映了子出错的机率(类似IGRP/EIGRP中的RELY)。

三.ISIS地址格式:

详见另一篇博文《理清ISIS、CLNS、NSAP、NET的关系》

四.ISIS基本运行:


基本配置:

router isis

     net 49.0001.0000.0000.0001.00 //此地址必须配置

Interface f0/0

     clns router isis //激活CLNS环境,实现NET地址通信(如果不需要NET通信,可以删除)

     ip router isis //激活IP环境,实现IP地址通信

优化配置:

router isis

      net 49.0001.0000.0000.0001.00

      is-type level-1  //设置路由器类型

interface f0/0

      ip router isis

      clns router isis

      isis ciruit-type level-1

查看命令:

 show isis neighbor

 show clns neighbor

 show clns is-neighbor

 show clns route

 show isis database

 show clns

 show clns interface f0/0

五. ISIS原理:

1.ISIS区域:

分为NET规划区域(49.00001)和手动配置区域两种。

手动配置区域:

L1区域--类似于OSPF完全末节区域L2区域--类似于OSPF骨干区域

2.路由器类型:is-type?

L1路由器--类似于OSPF非骨干路由器(完全末节区域路由器)

L2路由器--类似于OSPF骨干路由器(Area 0)

L1/L2路由器--类似于OSPF的ABR设备(默认类型),包含L1和L2数据库,但是它不像L1路由通告L2路由,所以它不向L1路由通告L2路由,所以L1不会学到区域外的路由,类似于完全末节区域。

3.接口类型:isis circuit-type?

level 1、Level-1-2、Level-2-only

4.DIS机制(类似OSPF DR/BDR机制):

角色:DIS IS

选举机制:

1.最大优先级,默认为64,为0则不参与选举

2.最大系统ID

切换机制:

有能力者居之,IS>DIS,立即切换(OSPF Dother>BDR>DR逐步切换)。

六.ISIS技术:

1.路由汇总:

R2(config)#router isis

R2(config-router)#summary-address172.16.0.0 255.255.252.0 ?

 level-1    Summarize into level-1area

 level-1-2  Summarize into botharea and sub-domain

 level-2    Summarize into level-2sub-domain

 metric     Set metric for summayroute

 tag        Set tag

 <cr>       //跟 level-2 效果一致,抑制精细路由,发送汇总路由。

Note:ISIS汇总自动生成 null0 路由。

 

2.路由认证:


链路认证:

方式一:

(config)#key chain R1R2

(config-keychain)#key 1

(config-keychain-key)#key-string12

(config)#in f0/0

(config-if)#isis authentication mode md5/text

(config-if)#isis authentication key-chainR1R2 level-1/level-2

方式二:

(config)#in f0/0

(config-if)#isis password XXX

 

区域认证:

方式一:

(config)#key chain R1R2

(config-keychain)#key 1

(config-keychain-key)#key-string12

(config)#router isis

(config-router)#authentication mode md5/text

(config-router)#isis authentication key-chain R1R2 level-1/level-2

方式二:

(config)#router isis

(config-router)#area-password 123//L1认证

(config-router)#domain-password123 //L2认证


3.被动接口:

(config)#router isis

(config-router)#passive-interfacef0/0

(config)#router isis

(config-router)#passive-interfacedefault

(config-router)#nopassive-interface f0/0

 

4.默认路由:

R5(config)#router isis

R5(config-router)#default-informationoriginate //跟RIP协议类似,不管自己有没有默认路由都会下发

 

七.ISIS特殊技术:

1.网络类型:BMA、P2P、NBMA

2.路由泄露:

ISIS路由泄露:就是把 L2 区域的具体的路由发布到 L1 区域当中去,从而是 L1 能够选择更优的路由。

详细可以参考:http://xghe110.blog.51cto.com/337884/106469/小麦的博客

 

原因:Y不知道X的精细路由,数据访问X时,走L1默认路由

需求:让Y知道X的精细路由(默认L2数据库信息不会交给L1数据库)

R2(config)#access-list 1 permit3.3.3.3 //抓取路由条目

R2(config)#route-map xielou

R2(config-route-map)#match ipaddress 1 //匹配ACL(路由条目)

R2(config)#router isis

R2(config-router)#redistribute isis ip level-2 into level-1 route-map xielou //调用


阅读更多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页