【POJ-1273】Drainage Ditches

【题目】
Drainage Ditches
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 58926 Accepted: 22620

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50


【代码c++】

使用的是最简单的EK+bfs算法。

EK算法 找到一条流然后添加到网络中。直到不存在一条流为止。

流: 除了开始点S和结束点E外的所有点i  有 SUM f(u,i) = SUM f(i,v).   并且S出的流量 = E进入的流量

然后找流的过程就是 bfs 搜索了。

#include <cstring>
#include <stdio.h>
#include <iostream>
#include <queue>
using namespace std;

const int maxn = 210;
int N,M;
int g[maxn][maxn]; //保存边的值
int pre[maxn];     //记录前一个结点
int cap[maxn];     //记录最大流量
int used[maxn];
const int INF = 0x3f3f3f3f;

int EK()
{
    int flow = 0;
    queue<int> q;

    while(1)
    {
        memset(pre,0,sizeof(pre));
        memset(cap,0,sizeof(cap));
        memset(used,0,sizeof(used));

        while(!q.empty())
            q.pop();

        q.push(0);
        used[0] = 1;
        pre[0] = -1;
        cap[0] = INF;

        while(!q.empty())
        {
            int cur = q.front();
            q.pop();

            for(int i=0;i<N;i++)
            {
                if(!used[i] && g[cur][i] > 0)
                {
                    cap[i] = min(cap[cur],g[cur][i]);
                    pre[i] = cur;
                    used[i] = 1;
                    q.push(i);
                }
            }
         }

         if(cap[N-1] == 0)
            break;

         flow += cap[N-1];

         for(int i=N-1;i!=0;i=pre[i])
         {
            g[pre[i]][i] -= cap[N-1];
            g[i][pre[i]] += cap[N-1];
         }
    }
    return flow;
}
int main()
{
    freopen("1.txt","r",stdin);
    while(scanf("%d%d",&M,&N) != EOF)
    {
        memset(g,0,sizeof(g));

        int u,v,c;
        for(int i=0;i<M;i++)
        {
            scanf("%d%d%d",&u,&v,&c);
            u--;
            v--;
            g[u][v] += c;
        }

        printf("%d\n",EK());
    }
}

 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值