【POJ1733】【Parity game】【map离散化】【加权并查集模板】

Parity game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7127 Accepted: 2763

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top




#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)


const int maxn = 10010;
int F[maxn];
int val[maxn];
map<int,int> mp;
int tot;
int insert(int x)
{
	if(mp.find(x) == mp.end()) mp[x] = tot++;
	return mp[x];
}

int find(int x)
{
	if(F[x] == -1) return x;
	int t = find(F[x]);
	val[x] ^= val[F[x]];
	return F[x] = t;
}
int main()
{

    int n,m;
	int u,v;
	char str[20];
	while(scanf("%d%d",&n,&m) == 2)
	{
		tot = 0;
		memset(F,-1,sizeof(F));
		memset(val,0,sizeof(val));
		mp.clear();
		int ans = m;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d%s",&u,&v,&str);
			if(u > v) swap(u,v);
			if(ans < m) continue;
			u = insert(u-1);
			v = insert(v);

			int tmp;
			if(str[0] == 'e') tmp = 0;
			 else tmp = 1;
			 int t1 = find(u);
			 int t2 = find(v);

			 if(t1 == t2)
			 {
				 if(val[u] ^ val[v] != tmp) ans = i;
			 }
			 else
			 {
				 F[t2] = t1;
				 val[t2] = tmp^val[u]^val[v];
			 }


		}
		printf("%d\n",ans);
	}
  
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值