字典树02

Hat’s Words
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
hdoj: http://acm.hdu.edu.cn/showproblem.php?pid=1247

Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 
Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 
Sample Input
a
ahat
hat
hatword
hziee
word
 
Sample Output
ahat
hatword

第二道字典树题,依然是参考了别人的代码后写的,新手上路~

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct Tree
{
	int flag;//标记这个节点是不是一个单词的结束
	Tree *next[26];
} *root;
void ptcre(char str[])
{
	Tree *s = root;
	for(int i = 0; i < strlen(str); i++)
	{
		if(s -> next[str[i] - 'a'])
			s = s -> next[str[i] - 'a'];
		else
		{
			Tree *t;
			t = (Tree*)malloc(sizeof(Tree));
			memset(t, 0, sizeof(Tree));
			t -> flag = 0;
			s -> next[str[i] - 'a'] = t;
			s = s -> next[str[i] - 'a']; 
		}
	}
	s -> flag = 1;
}
int judge(char str[])//判断输入的单词之前有没有出现过,即判断循环到单词末尾时这个节点是不是一个单词末尾
{
	Tree *s = root;
	for(int i = 0; i < strlen(str); i++)
	{
		if(!s -> next[str[i] - 'a'])
			return 0;
		else
			s = s -> next[str[i] - 'a'];
	}
	return s -> flag;
}
char verbs[50010][100];
main()
{
	root = (Tree*)malloc(sizeof(Tree));
	memset(root, 0, sizeof(Tree));
	char tmp1[100], tmp2[100];
	int count = 0;
	while(scanf("%s", verbs[count]) != EOF)
		ptcre(verbs[count++]);
	for(int i = 0; i < count; i++)
	{
		for(int j = 1; j < strlen(verbs[i]); j++)
		{
			strcpy(tmp1, verbs[i]);
			tmp1[j] = '\0';
			strcpy(tmp2, verbs[i] + j);//因为strcpy的参数是指针,这里巧妙的利用了这点将一个单词拆成了两份
			if(judge(tmp1) && judge(tmp2))
			{
				puts(verbs[i]);
				break;
			}
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值