UVa 10881 - Piotr's Ants

Piotr's Ants
Time Limit: 2 seconds

Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up T seconds from now.

Input

The first line of input gives the number of cases, N. N test cases follow. Each one starts with a line containing 3 integers: L , T and n (0 <= n <= 10000). The next n lines give the locations of the n ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).OutputFor each test case, output one line containing "Case #x:" followed by n lines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the same location, print "Turning" instead of "L" or "R" for their direction. If an ant falls off the pole before T seconds, print "Fell off" for that ant. Print an empty line after each test case.Sample Input Sample Output210 1 41 R5 R3 L10 R10 2 34 R5 L8 RCase #1:2 Turning6 R2 TurningFell offCase #2:3 L6 R10 R

#include <stdio.h>
#include <algorithm>

using namespace std;
struct Ant {
    int id; //输入顺序
    int p; //位置
    int d; //朝向。-1:左;0:转身中;1:右
    bool operator < (const Ant& a) const {
        return p < a.p;
    }
};

const int maxn = 10000 + 5;
const char dirName[][10] = {"L", "Turning", "R"};
int order[maxn]; //输入的第i只蚂蚁是终态中左数第order[i]只蚂蚁
Ant before[maxn], after[maxn];

int main() {
    int K;
    scanf("%d", &K);
    for (int k=1; k<=K; k++) {
        int L, T, n;
        printf("Case #%d:\n", k);
        scanf("%d%d%d", &L, &T, &n);
        for (int i=0; i<n; i++) {
            int p, d;
            char c;
            scanf("%d %c", &p, &c);
            d = (c == 'L' ? -1 : 1);
            before[i] = (Ant){i, p, d};
            after[i] = (Ant){0, p+T*d, d}; //这里的id是未知的
        }
        sort(before, before+n);
        for (int i = 0; i < n; i++)
            order[before[i].id] = i;
        sort(after, after + n);
        for (int i = 0; i < n - 1; i++) //修改碰撞中的蚂蚁的方向
            if (after[i].p == after[i + 1].p)
                after[i].d = after[i + 1].d = 0;
        for (int i = 0; i < n; i++) {
            int a = order[i];
            if (after[a].p < 0 || after[a].p > L)
                printf("Fell off\n");
            else
                printf("%d %s\n", after[a].p, dirName[after[a].d + 1]);
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值