POJ 1733 Parity game(哈希|离散+带权并查集)

7 篇文章 0 订阅
4 篇文章 0 订阅

Parity game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9402 Accepted: 3646
Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend’s answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.
Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either even' orodd’ (the answer, i.e. the parity of the number of ones in the chosen subsequence, where even' means an even number of ones andodd’ means an odd number).
Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.
Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd
Sample Output

3
Source

CEOI 1999

题意:

给定M个区间的奇偶性,问有多少个和之前的是冲突的

对于每一个询问x,y,z(even 则为0,odd则为1),
连一条y->x-1,权值为z的边
不相同则合并,新权值计算依靠根的相互关系和x-1~y的相互关系计算,(x-1~y实际应该连多少,可以算出fy~x应该连多少,再算fx~fy应该要多少,就算出来了新的权值)

相同则判断权值相减是不是符合

需要留意的是,x-1,y可能非常大,fa数组可能开不下,
第一种胆子大的人,开个几百万的数组多试几个mod就能过,但是这完全看脸,拼RP,不然就要写挂链hash
第二种先全部读进来离散,然后再做即可

离散的代码:

#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn=1e5+5;
int fa[maxn],d[maxn],n,m,x,y,z,len;
int a[maxn],b[maxn],c[maxn],h[maxn];
char s[10];

inline int get(int u)
{
  if(fa[u]==u)return u;
  int f=fa[u];
  fa[u]=get(fa[u]);
  d[u]=(d[f]+d[u])%2;
  return fa[u];
}

inline int getid(int x)
{
  return lower_bound(h+1,h+1+len,x)-h;
}

int main()
{
  while(~scanf("%d%d",&n,&m))
  {
    for(int i=1;i<=10005;++i)fa[i]=i,d[i]=0;
    int cnt=0;
    for(int i=1;i<=m;++i)
    {
      scanf("%d%d%s",&x,&y,s);
      if(s[0]=='e')z=0;else z=1;
      x--;
      h[cnt++]=x;h[cnt++]=y;
      a[i]=x;b[i]=y;c[i]=z;
    }

    sort(h+1,h+1+cnt);
    len=unique(h+1,h+1+cnt)-h-1;
    cnt=0;

    for(int i=1;i<=m;++i)
    {
      if(s[0]=='e')z=0;else z=1;
      x=getid(a[i]);y=getid(b[i]);z=c[i];
      int fx=get(x),fy=get(y);
      if(fx!=fy)
      {
        fa[fy]=fx;
        d[fy]=((z-d[y]+d[x])%2+2)%2;
      }
      else 
      {
        if(cnt==0&&(d[y]+z)%2!=d[x])cnt=i-1;
        //printf("%d\n",i);
      }
    }
    if(cnt)printf("%d\n",cnt);
    else printf("%d\n",m);
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值