HDU5775-Bubble Sort(逆序对)

Bubble Sort

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1542 Accepted Submission(s): 811

Problem Description
P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.

for(int i=1;i<=N;++i)
for(int j=N,t;j>i;—j)
if(P[j-1] > P[j])
t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.

Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.

Sample Input
2
3
3 1 2
3
1 2 3

Sample Output
Case #1: 1 1 2
Case #2: 0 0 0

Hint
In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3)
the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3
In second case, the array has already in increasing order. So the answer of every number is 0.

Author
FZU

Source
2016 Multi-University Training Contest 4

Recommend
wange2014

题意:

给定一个序列,问在冒泡排序过程中,没个数最大的移动范围是多少
由于是1-N,结果位置是知道的,
一个数能往右移最多是他的逆序对个数(在过程中某个时刻可以出现所有比他的大从他的初始的位置开始排列)即i-get(a[i])+a[i],然后l,r分别与i比较即可

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long LL;
const int maxn=1e5+5;

int T[maxn],kase,ans[maxn],n,a[maxn];

inline int get(int x)
{
  int res=0;
  for(;x;x-=x&-x)res+=T[x];
  return res;
}

inline void add(int x)
{
  for(;x<=n;x+=x&-x)T[x]++;
}

int main()
{
  int t;
  scanf("%d",&t);
  while(t--)
  {
    scanf("%d",&n);
    memset(ans,0,sizeof(ans));
    memset(T,0,sizeof(T));
    for(int i=1;i<=n;++i)scanf("%d",a+i);

    for(int i=1;i<=n;++i)
    {
      add(a[i]);
      int l=min(i,a[i]);
      int r=max(a[i],a[i]+i-get(a[i]));
      ans[a[i]]=r-l;      
    }
    printf("Case #%d:",++kase);
    for(int i=1;i<=n;++i)printf(" %d",ans[i]);
    printf("\n");
  }
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值