POJ-3468A Simple Problem with Integers(线段树区间修改)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 116429 Accepted: 36174
Case Time Limit: 2000MS
Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output

4
55
9
15
Hint

The sums may exceed the range of 32-bit integers.
Source

POJ Monthly–2007.11.25, Yang Yi

题意:

需要支持两种操作,区间求和,区间修改
线段树加lazy标记,就当写个版

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn=2e5+5;
int a[maxn]; 
LL T[4*maxn],tag[4*maxn],z; 
char opt[5];
int L,R,x,y,n,m;

inline void down(int l,int r,int k)
{
  tag[k<<1]+=tag[k];tag[k<<1|1]+=tag[k];
  int mid=(l+r)>>1;
  T[k<<1]+=(mid-l+1)*tag[k];
  T[k<<1|1]+=(r-mid)*tag[k];
  tag[k]=0;
}

inline void update(int k)
{
  T[k]=T[k<<1]+T[k<<1|1];
}

inline void build(int l,int r,int k)
{
  if(l==r)
  {
    T[k]=a[l];
    tag[k]=0;
    return;
  }
  int mid=(l+r)>>1;
  build(l,mid,k<<1);
  build(mid+1,r,k<<1|1);
  update(k);
  tag[k]=0;
}

inline LL ask(int l,int r,int k)
{
  if(L<=l&&r<=R)return T[k];
  int mid=(l+r)>>1;
  down(l,r,k);
  LL res=0;
  if(L<=mid)res+=ask(l,mid,k<<1);
  if(R>mid)res+=ask(mid+1,r,k<<1|1);
  return res;  
}

inline void add(int l,int r,int k)
{
  if(L<=l&&r<=R)
  {
    tag[k]+=z;
    T[k]+=(r-l+1)*z;
    return ;
  }
  int mid=(l+r)>>1;
  down(l,r,k);
  if(L<=mid)add(l,mid,k<<1);
  if(R>mid)add(mid+1,r,k<<1|1);
  update(k);
}

int main()
{
  while(~scanf("%d%d",&n,&m))
  {
    for(int i=1;i<=n;++i)scanf("%d",a+i);
    build(1,n,1);
    for(int i=1;i<=m;++i)
    {
      scanf("%s%d%d",opt,&x,&y);
      if(opt[0]=='Q')
      {
        L=x,R=y;
        printf("%lld\n",ask(1,n,1));
      }
      else
      {
        scanf("%lld",&z);
        L=x,R=y;
        add(1,n,1);
      }
    }
  }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值