HDU1532_Drainage Ditches(网络流/EK模板/Dinic模板(邻接矩阵/前向星))

17 篇文章 0 订阅
13 篇文章 0 订阅

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8599    Accepted Submission(s): 4005


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
 

Sample Input
  
  
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
  
  
50
 

Source
 解题报告
EK模板,不多说。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#define inf 99999999
#define N 220
#define M 220
using namespace std;
int n,m,edge[N][N],flow,a[N],p[N];
queue<int>Q;
void ek()
{
    while(1)
    {
        while(!Q.empty())
        Q.pop();
        memset(a,0,sizeof(a));
        memset(p,0,sizeof(p));
        Q.push(1);
        a[1]=inf;
        p[1]=1;
        while(!Q.empty())
        {
            int u=Q.front();
            Q.pop();
            for(int v=1;v<=n;v++)
            {
                if(!a[v]&&edge[u][v]>0)
                {
                    a[v]=min(a[u],edge[u][v]);
                    p[v]=u;
                    Q.push(v);
                }
            }
            if(a[n])break;
        }
        if(!a[n])break;
        for(int u=n;u!=1;u=p[u])
        {
            edge[p[u]][u]-=a[n];
            edge[u][p[u]]+=a[n];
        }
        flow+=a[n];
    }
}
int main()
{
    int i,j,u,v,w;
    while(~scanf("%d%d",&m,&n))
    {
        flow=0;
        memset(edge,0,sizeof(edge));
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            edge[u][v]+=w;
        }
        ek();
        printf("%d\n",flow);
    }
}

又学了Dinic算法。。。(基于邻接矩阵的),前向星不知道怎么处理反向弧。。。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#define inf 99999999
#define N 200
#define M 200
using namespace std;
int edge[N][N],flow,l[N],n,m;
int bfs()
{
    memset(l,-1,sizeof(l));
    queue<int>Q;
    l[1]=0;
    Q.push(1);
    while(!Q.empty())
    {
        int u=Q.front();
        Q.pop();
        for(int v=1;v<=n;v++)
        {
            if(edge[u][v]&&l[v]==-1)
            {
                l[v]=l[u]+1;
                Q.push(v);
            }
        }
    }
    if(l[n]>0)
    return 1;
    else return 0;
}
int dfs(int x,int f)
{
    if(x==n)return f;
    int a;
    for(int i=1;i<=n;i++)
    {
        if(edge[x][i]&&(l[i]==l[x]+1)&&(a=dfs(i,min(f,edge[x][i]))))
        {
            edge[x][i]-=a;
            edge[i][x]+=a;
            return a;
        }
    }
    return 0;
}
int main()
{
    int i,j,u,v,w;
    while(~scanf("%d%d",&m,&n))
    {
        memset(edge,0,sizeof(edge));
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            edge[u][v]+=w;
        }
        int a=0;
        flow=0;
        while(bfs())
            while(a=dfs(1,inf))
            flow+=a;
        printf("%d\n",flow);
    }
    return 0;
}

终于觉醒了,之前看了一串非递归的前向星dinic,,,老觉得不对,,,换了一种思路,写成递归调用dfs和邻接表一样,对于处理反向弧加流的话在建边的时候处理,建边一次建两条,正向和反向,这样就知道,反向弧在哪里了,,,
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#define N 300
#define M 30000
#define inf 99999999
using namespace std;
struct node
{
    int u,v,w,r,next;
}edge[M];

int n,m,head[N],l[N],cnt;
void add(int u,int v,int w)
{
    edge[cnt].u=u;
    edge[cnt].v=v;
    edge[cnt].w=w;
    edge[cnt].next=head[u];
    edge[cnt].r=cnt+1;
    head[u]=cnt++;
    edge[cnt].u=v;
    edge[cnt].v=u;
    edge[cnt].w=0;
    edge[cnt].next=head[v];
    edge[cnt].r=cnt-1;
    head[v]=cnt++;
}
int bfs()
{
    queue<int >Q;
    while(!Q.empty())
    Q.pop();
    Q.push(1);
    memset(l,-1,sizeof(l));
    l[1]=0;
    while(!Q.empty())
    {
        int u=Q.front();
        Q.pop();
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            if(edge[i].w&&l[edge[i].v]==-1)
            {
                l[edge[i].v]=l[u]+1;
                Q.push(edge[i].v);
            }
        }
    }
    if(l[n]>0)return 1;
    else return 0;
}
int dfs(int x,int f)
{
    int i,a;
    if(x==n)return f;
    for(i=head[x];i!=-1;i=edge[i].next)
    {
        if(edge[i].w&&l[edge[i].v]==l[x]+1&&(a=dfs(edge[i].v,min(f,edge[i].w))))
        {
            edge[i].w-=a;
            edge[edge[i].r].w+=a;
            return a;
        }
    }
    return 0;
}
int main()
{
    int i,j,u,v,w;
    while(cin>>m>>n)
    {
        memset(head,-1,sizeof(head));
        memset(edge,0,sizeof(edge));
        cnt=0;
        for(i=0;i<m;i++)
        {
            cin>>u>>v>>w;
            add(u,v,w);
        }
        int ans=0,a;
        while(bfs())
            while(a=dfs(1,inf))
            ans+=a;
        cout<<ans<<endl;
    }
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值