冒泡排序——HDU 2689

对应HDU题目:点击打开链接


Sort it

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2460    Accepted Submission(s): 1769


Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
 

Output
For each case, output the minimum times need to sort it in ascending order on a single line.
 

Sample Input
  
  
3 1 2 3 4 4 3 2 1
 

Sample Output
  
  
0 6


#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
#define ms(x,y) memset(x,y,sizeof(x))
const int MAXN=1000+10;
const int INF=1<<30;
using namespace std;
int a[MAXN];

int main()
{
	//freopen("in.txt","r",stdin);
	int n;
	while(scanf("%d", &n)==1)
	{
		int i,j;
		int count=0;
		for(i=0; i<n; i++) scanf("%d", &a[i]);
		for(i=1; i<=n; i++){
			int ok=0;
			for(j=0; j<n-i; j++){
				ok=1;
				if(a[j]>a[j+1]){
					count++;
					int tmp=a[j];
					a[j]=a[j+1];
					a[j+1]=tmp;
				}
			}
			if(!ok) break;
		}
		printf("%d\n", count);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值