Composer 学习笔记

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/u013372487/article/details/71379594

Composer – 是一个新的安装包管理工具,服务于 PHP 生态系统(PHP依赖管理工具)

包含了两个部分:Composer 和 Packagist。

Composer

Composer 是一个命令行工具,它的使命就是帮你为项目自动安装所依赖的开发包。Composer 包含了一个依赖解析器,用来处理开发包之间复杂的依赖关系;另外,它还包含了下载器、安装器等。

Packagist

Packagist 是 Composer 的默认的开发包仓库。你可以将自己的安装包提交到 packagist,将来你在自己的 VCS (源码管理软件,比如 Github)仓库中新建了 tag 或更新了代码,packagist 都会自动构建一个新的开发包。

Composer安装教程:

安装 Composer(全局安装)

#这个命令会将 composer.phar 下载到当前目录。PHAR(PHP 压缩包)是一个压缩格式,可以在命令行下直接运行。

$ curl -sS https://getcomposer.org/installer | php

$ mv composer.phar /usr/local/bin/composer

注意:

由于数据源https://getcomposer.org/installer在国外,经常导致链接失败以致于上面命令无法执行,可使用一下方法解决:

在浏览器上打开链接 https://getcomposer.org/download/  下载composer最新版本的 composer.phar 文件,导入到安装目录下,执行以下命令:

$ mv composer.phar /usr/local/bin/composer

Composer使用教程:

1、声明依赖

在项目目录下创建一个 composer.json 文件,指明依赖,比如,你的项目依赖 monolog:

(composer.json 文件中声明当前项目所依赖的开发包)

示例:

{
    "require": {
        "php": ">=5.5.9",     #php版本限制,若您当前版本小于该版本,会报错(可有可无)
        "monolog/monolog": "1.2.*"     #引入包 
    }
}

添加镜像的配置信息:

https://packagist.phpcomposer.com是国内composer镜像资源站,防止被墙导致的引入失败

进入项目的根目录(也就是 composer.json 文件所在目录),执行如下命令:

composer config repo.packagist composer https://packagist.phpcomposer.com

上述命令将会在当前项目中的 composer.json 文件的末尾自动添加镜像的配置信息(你也可以自己手工添加):

"repositories": {
    "packagist": {
        "type": "composer",
        "url": "https://packagist.phpcomposer.com"
    }
}

具体composer.json文件配置项见链接:
http://docs.phpcomposer.com/04-schema.html

2、安装依赖

安装依赖非常简单,只需在项目目录下运行:

composer install

成功运行完毕,会在根目录下发现vendor文件夹,里面包含了刚刚我们列出来的依赖包文件代码。

3、自动加载

Composer 提供了自动加载的特性,只需在你的代码的初始化部分中加入下面一行:

require 'vendor/autoload.php';

Composer更新

经常执行以下命令,保持 Composer 是最新版本!

composer selfupdate
展开阅读全文

没有更多推荐了,返回首页