uva 10420(排序)

题目:

In Act I, Leporello is telling Donna Elvira about his master's long list of conquests:

``This is the list of the beauties my master has loved, a list I've made out myself: take a look, read it with me. In Italy six hundred and forty, in Germany two hundred and thirty-one, a hundred in France, ninety-one in Turkey; but in Spain already a thousand and three! Among them are country girls, waiting-maids, city beauties; there are countesses, baronesses, marchionesses, princesses: women of every rank, of every size, of every age.'' (Madamina, il catalogo è questo)

As Leporello records all the ``beauties'' Don Giovanni ``loved'' in chronological order, it is very troublesome for him to present his master's conquest to others because he needs to count the number of ``beauties'' by their nationality each time. You are to help Leporello to count.

input

The input consists of at most 2000 lines, but the first. The first line contains a number n, indicating that there will be n more lines. Each following line, with at most 75 characters, contains a country (the first word) and the name of a woman (the rest of the words in the line) Giovanni loved. You may assume that the name of all countries consist of only one word.

output

The output consists of lines in alphabetical order. Each line starts with the name of a country, followed by the total number of women Giovanni loved in that country, separated by a space.

sample input

3
Spain Donna Elvira
England Jane Doe
Spain Donna Anna

sample output

England 1
Spain 2

题解:得到第一个国家的单词,然后将单词排序,并输出单词出现的次数。

#include <iostream>
#include <string>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int cmp(const void *s1, const void *s2) {
	return strcmp((char *)s1, (char *)s2);
}
int main(){
	int n, num = 1;
	char s[2005][100];
	string a;
	cin >> n;
	getchar();
	for (int i = 0; i < n; i++) {
		scanf("%s", s[i]);
		getline(cin, a);
	}
	qsort(s, n, sizeof(s[0]), cmp);
	for (int j = 1; j < n; j++)
		if (strcmp(s[j - 1], s[j]) != 0) {
			printf("%s %d\n", s[j - 1], num);
			num = 1;
		}
		else
			num++;
	printf("%s %d\n", s[n - 1], num);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值