50 years, 50 colors

Description

On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".       

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.       

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.       


              

Input

There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.       
              

Output

For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".       
              

Sample Input

    
    
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0
              

Sample Output

    
    
-1 1 2 1 2 3 4 5 -1

 

题意:一个n*n矩阵,每个格子放一个气球,气球有颜色。一个人一次可以选择一种颜色的气球,再选择一行或者一列,把该种颜色的气球踩破;

你有k次机会,看否把某种颜色的气球全部踩破。若有些颜色的气球不能被踩破,按从小大的顺序输出这些气球。否则,输出-1.

在二分图中求最少的点,让每条边都至少和其中的一个点关联,这就是二分图的“最小顶点覆盖”。

二分图的最小顶点覆盖数 =二分图的最大匹配数

 

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int vist[1100];
int map[1100][1100],color[1100],col[1100];
int flag[1100],flag1[1000];
int n,k,m,l;
void init()
{
    memset(vist,-1,sizeof(vist));
    memset(map,0,sizeof(map));
    memset(flag1,0,sizeof(flag1));
}
int find(int i,int ol)
{
    int j;
    for(j=1; j<=n; j++)
    {
        if(!flag[j]&&map[i][j]==ol)
        {
            flag[j]=1;
            if(vist[j]==-1||find(vist[j],ol))
            {
                vist[j]=i;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&k)&&n&&k)
    {
        init();
        m=0,l=0;
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                scanf("%d",&map[i][j]);
                if(!flag1[map[i][j]])
                {
                    color[m++]=map[i][j];//记录所有的颜色
                    flag1[map[i][j]]=1;
                }
            }
        }
        sort(color,color+m);//因为最后输出是按顺序的
        int sum;
        for(i=0; i<m; i++)//对每个颜色进行判断
        {
            sum=0;
            memset(vist,-1,sizeof(vist));
            for(j=1; j<=n; j++)
            {
                memset(flag,0,sizeof(flag));
                if(find(j,color[i]))
                    sum++;
            }
            if(sum>k)
            {
                col[l++]=color[i];
            }
        }
        if(l==0)
            printf("-1\n");
        else
        {
            for(i=0; i<l; i++)
            {
                if(i==l-1)
                    printf("%d\n",col[i]);
                else
                    printf("%d ",col[i]);
            }
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值