zoj 1097 优先队列

Code the Tree

Time Limit: 2 Seconds       Memory Limit: 65536 KB

A tree (i.e. a connected graph without cycles) with vertices numbered by the integers 1, 2, ..., n is given. The "Prufer" code of such a tree is built as follows: the leaf (a vertex that is incident to only one edge) with the minimal number is taken. This leaf, together with its incident edge is removed from the graph, while the number of the vertex that was adjacent to the leaf is written down. In the obtained graph, this procedure is repeated, until there is only one vertex left (which, by the way, always has number n). The written down sequence of n-1numbers is called the Prufer code of the tree. 
Your task is, given a tree, to compute its Prufer code. The tree is denoted by a word of the language specified by the following grammar:

T ::= "(" N S ")"
S ::= " " T S
    | empty
N ::= number
That is, trees have parentheses around them, and a number denoting the identifier of the root vertex, followed by arbitrarily many (maybe none) subtrees separated by a single space character. As an example, take a look at the tree in the figure below which is denoted in the first line of the sample input.

Note that, according to the definition given above, the root of a tree may be a leaf as well. It is only for the ease of denotation that we designate some vertex to be the root. Usually, what we are dealing here with is called an "unrooted tree".

Input Specification

The input contains several test cases. Each test case specifies a tree as described above on one line of the input file. Input is terminated by EOF. You may assume that 1<=n<=50.

Output Specification

For each test case generate a single line containing the Prufer code of the specified tree. Separate numbers by a single space. Do not print any spaces at the end of the line.

Sample Input

(2 (6 (7)) (3) (5 (1) (4)) (8))
(1 (2 (3)))
(6 (1 (4)) (2 (3) (5)))

Sample Output

5 2 5 2 6 2 8
2 3
2 1 6 2 6

import java.io.BufferedInputStream;
import java.io.PrintWriter;
import java.util.ArrayList;
import java.util.List;
import java.util.PriorityQueue;
import java.util.Scanner;


public class Main {
	
	public static void main(String[] args) {
		new Task().solve();
	}
}

class Task {
	Scanner in = new Scanner(new BufferedInputStream(System.in)) ;
	PrintWriter out = new PrintWriter(System.out);

	List<Integer>[] adj = new List[51] ;
	String line ;
	void read(int p){
		int l = line.indexOf("(") ;
		int r = line.indexOf(")") ;
		int i = -1 ;
		if(l == -1){
			i = r ;
		}
		else if(r == -1){
			i = l ;
		}
		else{
		    i = Math.min(line.indexOf("(") , line.indexOf(")")) ;
		}
	    int x = Integer.valueOf(line.substring(0, i)) ;
		if(p > 0){
	    	adj[p].add(x) ;
	    	adj[x].add(p) ;
	    }
		line = line.substring(i) ;
		while(true){
			char ch = line.charAt(0) ;
			line = line.substring(1) ;
			if(ch == ')'){
				break ;
			}
			else{
				read(x);
			}
		}
	}
	
	void solve() {
		while(in.hasNext()){
			line = in.nextLine().replaceAll(" ", "").substring(1) ;
			for(int i = 1 ; i <= 50 ; i++){
				adj[i] = new ArrayList<Integer>() ;
			}
			read(0) ;
			PriorityQueue<Integer> q = new PriorityQueue<Integer>() ;
			int n = 0 ; 
			for(int i = 1 ; i <= 50 ; i++){
				if(! adj[i].isEmpty()){
					n++ ;
				}
				if(adj[i].size() == 1){
					q.add(i) ;
				}
			}
			for(int k = 1 ; k < n ; k++){
				int u = q.poll() ;
				int v = adj[u].get(0) ;
				out.print((k == 1 ? "" : " ") + v) ;
				adj[v].remove(Integer.valueOf(u)) ;
				if(adj[v].size() == 1){
					q.add(v) ;
				}
			}
			out.println();
			//out.flush();
		}
		out.flush();
	}
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值