Counting Triangles

描述

Given an equilateral triangle with n the length of its side, program to count how many triangles in it.



输入

The length n (n <= 500) of the equilateral triangle's side, one per line.
process to the end of the file

输出

The number of triangles in the equilateral triangle, one per line.

样例输入

1
2
3

样例输出

1
5
13

#include<iostream>
using namespace std;

int main(){
	int triangle[502]={0,1},i;
	for(i=2;i<=500;i+=2){
		triangle[i]=triangle[i-1]+i*(i+1)/2+i/2+(i/2)*(i/2-1);
		triangle[i+1]=triangle[i]+(i+1)*(i+2)/2+(i/2)*(i/2+1);
	}
	while(scanf("%d",&i)==1)
		cout<<triangle[i]<<endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值