SZ Fibonacci Sequence

描述

Fibonacci Sequence is familiar to you,right?Here comes the SZ fibonaccisequence,with the property like Formula 3.1.1

                        a,       n=1;

                        b,       n=2

F(n)=                   F(n-1)+F(n-2)      n>2 and n is odd;

                        F(n-1)+F(n-2)+F(n-3)  n>3and n is even;

 

Here a and b are constants.Gaven a,b and n,your task is to calculate the F(n)

 

输入

First line of input comes a positive integer T(T<=10),indicating the number of test cases.Each test casecontains three positive integer a,b and n(a<=10,b<=10,n<=30).

输出

print one linr containing an integer,i,e.F(n),for each test case.

样例输入

2
1 2 3
1 3 6

样例输出

3
24

#include<iostream>
using namespace std;

int main(){
	__int64 f[31];
	int i,t,n;
	cin>>t;
	while(t--){
		scanf("%I64d %I64d %d",&f[1],&f[2],&n);
		for(i=3;i<=n;i+=2){
			f[i]=f[i-1]+f[i-2];
			f[i+1]=f[i]+f[i-1]+f[i-2];
		}
		printf("%I64d\n",f[n]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值