All in All

All in All

时间限制(普通/Java):3000MS/10000MS          运行内存限制:65536KByte
总提交:22            测试通过:16

描述

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

输入

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

输出

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

样例输入

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

样例输出

Yes
No
Yes
No


#include<iostream>
using std::cin;
using std::cout;
using std::endl;
#include<string>
using std::string;

bool check(const string& src, const string& str){
	string::size_type src_len(src.length()), str_len(str.length());
	for (string::size_type src_counter(0), str_counter(0); str_counter != str_len; ++str_counter){
		if (src[src_counter] == str[str_counter]){
			++src_counter;
		}
		if (src_counter == src_len){
			return true;
		}
	}
	return false;
}

int main(void){
	string source, result;
	while (cin >> source >> result){
		cout << (check(source, result) ? "Yes" : "No") << endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值