Number

Number

时间限制(普通/Java):1000MS/3000MS          运行内存限制:65536KByte
总提交:23            测试通过:20

描述

Given an equation (a*x+b)%n=0,where a,b,n are positive integer ,please find out the least positive integer x make that equation holds.

输入

There are several test cases .one line for each case ,For each line ,three positive integers,all of which are no than 2000000000.Input number have no leading zeros .There will be no more than 1000 teat cases.

Input is ended with three 0.

输出

  Output each result in a single line .Output number must not have any leading zeros.If there is no positive integer makes the equation holds ,then output -1. 

样例输入

1 1 1 
1 1 2
1 1 3
3 4 5
5 1 5
0 0 0

样例输出

1
1
2
2
-1

#include<iostream>

int main(void){
	unsigned int a, b, n;
	unsigned int x;
	while (scanf("%u%u%u", &a, &b, &n), a && b && n){
		if (a % n == 0 && b % n != 0){
			printf("-1\n");
		}
		else{
			for (x = 1; (a * x + b) % n != 0; ++x){
				continue;
			}
			printf("%u\n", x);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值