POJ 3267-The Cow Lexicon(DP处理字符串)

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L
Line 2: L characters (followed by a newline, of course): the received message
Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

                                                                           

题意:求一字符串中至少删去多少字母才能由所给单词组成。

思路:一开始试图用最长公共子序列的思路水过,那是不可能的~

           看了题解,思路应该从最多有几个字母是匹配的,纠正为最少要删去多少个字母。dp[ i ]指的是从i 到 L-1 的子段中最少要删除几个字母。

CODE:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;

string s,w[605];
int dp[605];
int main()
{
    //freopen("in","r",stdin);
    int W,L;
    scanf("%d %d", &W,&L);
    cin>>s;
    for(int i=0; i<W; i++){
        cin>>w[i];
    }
    dp[L]=0;
    for(int i=L-1; i>=0; i--){
        dp[i]=dp[i+1]+1;//最坏的情况不匹配。
        for(int j=0; j<W; j++){
            int len=w[j].size();
            int a=i,b=0;
            if(w[j][b] == s[i] && len<=L-i){
                while(a<L){
                    if(w[j][b] != s[a]){
                        a++;
                    }
                    else{
                        b++;
                        a++;
                    }
                    if(b==len && a<=L){
                        dp[i] = min(dp[i], dp[a]+(a-i)-len);
                        break;
                    }
                }
            }
        }
    }
    printf("%d\n", dp[0]);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值