UvaOJ 10010 Where's Waldorf?

Uvaoj 题目

Given a m by n grid of letters, ( $1 \leq m,n \leq 20$), and a list of words, find the location in the grid at which the word can be found. A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters in the grid regardless of case (i.e. upper and lower case letters are to be treated as the same). The matching can be done in any of the eight directions either horizontally, vertically or diagonally through the grid.

Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

The input begins with a pair of integers, m followed by n$1 \leqm,n \leq 50$ in decimal notation on a single line. The next m lines contain n letters each; this is the grid of letters in which the words of the list must be found. The letters in the grid may be in upper or lower case. Following the grid of letters, another integer k appears on a line by itself ( $1 \leq k \leq 20$). The next k lines of input contain the list of words to search for, one word per line. These words may contain upper and lower case letters only (no spaces, hyphens or other non-alphabetic characters).

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For each word in the word list, a pair of integers representing the location of the corresponding word in the grid must be output. The integers must be separated by a single space. The first integer is the line in the grid where the first letter of the given word can be found (1 represents the topmost line in the grid, and m represents the bottommost line). The second integer is the column in the grid where the first letter of the given word can be found (1 represents the leftmost column in the grid, and n represents the rightmost column in the grid). If a word can be found more than once in the grid, then the location which is output should correspond to the uppermost occurence of the word (i.e. the occurence which places the first letter of the word closest to the top of the grid). If two or more words are uppermost, the output should correspond to the leftmost of these occurences. All words can be found at least once in the grid.

Sample Input 

1

8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
4
Waldorf
Bambi
Betty
Dagbert

Sample Output 

2 5
2 3
1 2
7 8
我的思路:以一个字母为起点,向其八个方向搜索,若有一个方向能搜到完整的与下面输入对应的单词,就返回该起始字母的位置坐标/好像就是这样。对了,有一点特别提醒,注意大小写的统一和输入时对于空行的处理

   下面是我的代码:

#include <stdio.h>
#include <iostream>
#include <cctype>
#include <cstring>
using namespace std;
int m,n,k,xx,yy;
char a[1005][1005];
int tx[]={0,0,1,-1,-1,1,1,-1};//用于方向
int ty[]={1,-1,0,0,1,-1,1,-1};
char abc(int xx,int yy)
{
    if(xx>=0&&xx<n&&yy>=0&&yy<k)
        return a[xx][yy];
    return '0';//‘0’可以用任何非字母的字符代替
}
void p(string b,int &x,int &y)/*void 型的函数,没有返回值这
里的int &x,必须有&,而在后面调用时就不用加*/
{
    int i,j,l,e,find;
    for(i=0;i<n;i++)
       for(j=0;j<k;j++)
          for(l=0;l<8;l++)// 每一个方向都要搜到
          {
              find=0;
              for(e=0;e<b.length();e++)
              {
                if(abc(i+tx[l]*e,j+ty[l]*e)==b[e])
                     find++;
                else
                      break;//结束这一方向的搜索,进入判断
              }
                if(find==b.length())//判断成功则结束函数,否则l++;进入另一个方向的搜索,
                {
                    x=i;
                    y=j;
                    return;//注意写法。可看做用它来结束函数!
                }
          }
}
int main()
{
    int l,i,j,count,z;
    cin >> z;//至于输入不建议用scanf(),因为用到字符串,还要考虑‘\n’,不如cin
    while(z--)
    {
       string cmp;
       getline(cin,cmp);//空行的写法
       cin >> n >> k;
       for(i=0;i<n;i++)
         for(j=0;j<k;j++)
         {
             cin >> a[i][j];
             if(islower(a[i][j]))//全变成大写,下同
                 a[i][j]=toupper(a[i][j]);
         }
       cin >> l;
       while(l--)
       {
           count=1;
           string b;
           cin >> b;
           for(i=0;i<b.length();i++)
               if(islower(b[i]))
                   b[i]=toupper(b[i]);
           int x1,y1;
            p(b,x1,y1);
           cout << x1+1<<" "<< y1+1<<endl;
       }
       if(z!=0)
          cout << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值