hdu 2602 背包问题之01背包

http://acm.hdu.edu.cn/showproblem.php?pid=2602

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
    这是我的第一个背包问题。纪念一下,啦啦啦~~

5 10

2 3 4 5

5 4 3 2 1

横向表示w(空间,从0开始),竖向表示物品数(从1开始)。对于这个示例数据;我的程序模拟演示如下,请看表格:(列之所以从零开始,是因为骨头的重量可能为零,至于为什么,就留给读者了)  

解释:比如,第一行,第一列表示:现在考虑第一个物品(1,5)对于空间为零(列号表示空间大小)不能装下,所以f[1][0]=0,而第一行第二列空间就变成了1,可以装下第一个物品,故f[1][1]=5。再如,第二行第四列,对于第二个物品(2,4)在装了第一个后还剩空间为2,正好装下,故f[2][3]=5+4;以此类推……(看不懂自己画画表格再模拟一下)

05555555555
05599999999
0559991212121212
0559991212121214
0559991212121214

如果你在自己写代码,试试这组数据,这个过了,基本上就AC了,

1
5 0
2 4 1 5 1
0 0 1 0 0
答案是12
下面是我写的:
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
int f[1005][1005],w[1005],v[1005];
int main()
{
    int m;
    scanf("%d",&m);
    while(m--)
    {
        memset(f,0,sizeof(f));// 先清零是很必要的
        memset(w,0,sizeof(w));
        memset(v,0,sizeof(v));
        int n,V;
        scanf("%d%d",&n,&V);
        for(int i=1;i<=n;i++)
           cin >> v[i];
        for(int i=1;i<=n;i++)
           cin >> w[i];
        for(int i=1;i<=n;i++)
            for(int j=0;j<=V;j++)
            {
                f[i][j]=f[i-1][j];
                if(j>=w[i]&&f[i][j]<f[i-1][j-w[i]]+v[i])
                    f[i][j]=f[i-1][j-w[i]]+v[i];
            }
         cout <<f[n][V]<< endl;
    }
    return 0;
}

若用一位数组来解决的话

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
int f[1005],w[1005],v[1005];
int main()
{
    int m;
    scanf("%d",&m);
    while(m--)
    {
        memset(f,0,sizeof(f));// 先清零是很必要的
        memset(w,0,sizeof(w));
        memset(v,0,sizeof(v));
        int n,V;
        scanf("%d%d",&n,&V);
        for(int i=1;i<=n;i++)
           cin >> v[i];
        for(int i=1;i<=n;i++)
           cin >> w[i];
        for(int i=1;i<=n;i++)
        {
            for(int j=V;j>=w[i];j--)
            {
                f[j]=max(f[j],f[j-w[i]]+v[i]);
               //cout << f[j] << " ";
            }
          //  cout << endl;
        }
      //  for(int i=0;i<=V;i++)
      //   cout <<f[i]<< endl;
      cout << f[V]<< endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值