poj 3259 判断是否存在负权环

http://poj.org/problem?id=3259

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
题目大意:

                 农夫的农场里存在n块地,存在m条无向路,从每条路的一段到另一端需要花费t的时间,存在w个虫洞,每个虫洞都是单向的从虫洞的起点到虫洞的终点需要-t的时间,也就是时间倒流了。现在农夫要从一块田地出发再回到原出发点,问他能否在回到出发点的时候比刚出发是时间要早。

解题思路:

                  模型就是一张有负权边的图网络,若能回到原出发点的时候会时间不出发时还少,那就说明一定存在这负权边。这样一来,这道题就变成了判断是否存在负权边了。

在spfa算法中,如果以个顶点入队次数超过了n次,那就说明存在了负权边。


#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
const int maxn=1e5;
const int INF=1e9;
int dis[maxn],head[maxn],visit[maxn],outque[maxn];
int ip,que[maxn],flag;
struct node
{
    int to;
    int next;
    int w;
};
node edge[maxn];
void add(int u,int v,int w)
{
    edge[ip].to=v,edge[ip].w=w,edge[ip].next=head[u],head[u]=ip++;
}
void spfa(int s,int n)
{
    memset(visit,0,sizeof(visit));
    memset(outque,0,sizeof(outque));
    for(int i=0;i<=n;i++)
        dis[i]=INF;
    dis[s]=0;
    visit[s]=1;
    int front=-1,tail=-1;
    que[++tail]=s;
    int top,to;
    int temp;
    while(front!=tail)
    {
        if(++front>n)
            front-=n;
        top=que[front];
        outque[top]++;//入队次数加加
        if(outque[top]>n)//入队次数大于n,存在负权环。算法结束
        {
            flag=0;
            //printf("&&\n");
            return;
        }
        visit[top]=0;
        for(int k=head[top];k!=-1;k=edge[k].next)
        {
            to=edge[k].to;
            temp=dis[top]+edge[k].w;
            if(dis[to]>temp)
            {
                dis[to]=temp;
                if(!visit[to])
                {
                    if(++tail>n)
                       tail-=n;
                    que[tail]=to;
                    visit[to]=1;
                }
            }
        }

    }
}

int main()
{
    int T,m,k,u,v,w,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&k);
        memset(head,-1,sizeof(head));
        ip=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            add(u,v,w);
            add(v,u,w);
        }
        for(int i=0;i<k;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            add(u,v,-w);
        }
        flag=1;
        spfa(1,n);
         if(!flag)
            printf("YES\n");
         else
            printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值