uva 11478 最短路径问题(负环,差分约束系统)

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=2473

You are given a directed graph G(V,E) with a set of vertices and edges. Each edge (i,j) that connects some vertex i to vertex j has an integer cost associated with that edge.
 
Define the operation Halum(v, d) to operate on a vertex v using an integer d as follows: subtract d from the cost of all edges that enter v and add d to the cost of every edge that leaves v.

As an example of that operation, consider graph G that has three vertices named (1, 2, 3) and two edges. Edge (1, 2) has cost -1, and edge (2,3) has cost 1. The operation Halum(2,-3) operates on edges entering and leaving vertex 2.  Thus, edge (1, 2) gets cost -1-(-3)=2 and the edge (2, 3) gets cost 1 + (-3) = -2.

Your goal is to apply the Halum function to a graph, potentially repeatedly, until every edge in the graph has at least a certain cost that is greater than zero. You have to maximize this cost.

 

 
 Input  
 

Two space-separated integers per case: V(V≤500) and E(E≤2700)E lines follow. Each line represents a directed edge using three space-separated integers (u, v, d). Absolute value of cost can be at most 10000.

 
   
 Output 
 

If the problem is solvable, then print the maximum possible value. If there is no such solution print “No Solution”. If the value can be arbitrary large print “Infinite”

 
   
 Sample InputSample Output  
 

2 1
1 2 10
2 1
1 2 -10
3 3
1 2 4
2 3 2
3 1 5
4 5
2 3 4
4 2 5
3 4 2
3 1 0
1 2 -1


Infinite
Infinite
3
1


题目大意:给定一个有向图,每条边都有一个权值。每次你可以选择一个节点v,和一个整数d把所有的以v为终点的边的权值减小d,把所有的边的权值减小d,把所有的以v为起点的边的权值增加d,最后要让所有的边权的最小值非负且最大,输出满足这种情况的d的最大值。如果无法让所有边权都非负,输出“No Solution”,如果边权可以任意大那么输出“Infinite”。

分析:注意,不同的操作互不影响,因此可以按任意的顺序实施这些操作。另外对于同一个节点的多次操作也可合并,因此可以令sum(u),为作用于节点u之上的所有d之和,这样,本题的目标就是确定所有的sum(u),使得操作之后的所有的边权的最小值尽量大。

“最小值最大”又让我们想到了二分答案。二分答案x后,问题转化为是否可以让操作完毕后的每条边的权值均不小于x。对于边a-》b,不难发现操作完毕之后它的权值为w(a,b)+sum(a)-sum(b),一次每条边都可以列出一个不等式w(a,b)+sum(a)-sum(b)>=x,移项得sum(b)-sum(a)<=w(a,b)-x;这样我们实际上就得到了一个差分约束系统。


#include <stdio.h>
#include <string.h>
#include <iostream>
#include <queue>
using namespace std;
const int INF=9999999999;
const int N=503;
struct note
{
    int to,w,next;
}edge[N*N];
int head[N],ip,m,n;
int cnt[N],dis[N],in[N];
void addedge(int u,int v,int w)
{
    edge[ip].to=v,edge[ip].w=w,edge[ip].next=head[u],head[u]=ip++;
}
void init()
{
    memset(head,-1,sizeof(head));
    ip=0;
}
bool spfa(int s)
{
    queue<int> q;
    for(int i=0;i<=n;i++)
    {
        dis[i]=INF;
        in[i]=false;
        cnt[i]=0;
    }
    dis[s]=0;
    in[s]=true;
    cnt[s]++;
    q.push(s);
    while(!q.empty())
    {
        int u=q.front();
        in[u]=false;
        q.pop();
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            int v=edge[i].to;
            if(dis[u]+edge[i].w<dis[v])
            {
                dis[v]=dis[u]+edge[i].w;
                if(!in[v])
                {
                    q.push(v);
                    in[v]=true;
                    if(++cnt[v]>=n+1)
                        return false;
                }
            }
        }
    }
    return true;
}
bool jud(int x)
{
    bool flag=1;
    for(int i=0;i<=n;i++)
        for(int j=head[i];j!=-1;j=edge[j].next)
            edge[j].w-=x;
    if(!spfa(0)) flag=0;
    for(int i=0;i<=n;i++)
        for(int j=head[i];j!=-1;j=edge[j].next)
             edge[j].w+=x;
    return flag;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        init();
        int u,v,w;
        int maxx=-INF;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            addedge(u,v,w);
            maxx=max(maxx,w);
        }
        for(int i=1;i<=n;i++)
            addedge(0,i,0);
        if(jud(maxx+1)) printf("Infinite\n");
        else if(!jud(1))printf("No Solution\n");
        else
        {
            int mid,l=1,r=maxx,ans=1;
            while(l<=r)
            {
                mid=(l+r)>>1;
                if(jud(mid))//小的满足再判断大的是否可以,因为要取大的
                {
                    ans=mid;
                    l=mid+1;
                }
                else
                    r=mid-1;
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值