UVA 1374 迭代加深搜索

http://vjudge.net/contest/view.action?cid=50643#problem/C

Starting with x and repeatedly multiplying by x, we can compute x31 with thirty multiplications:

x2 = x x x,      x3 = x2 x x,      x4 = x3 x x,      ...  ,      x31 = x30 x x.
The operation of squaring can appreciably shorten the sequence of multiplications. The following is a way to compute  x31 with eight multiplications:
x2 = x x x,      x3 = x2 x x,      x6 = x3 x x3,      x7 = x6 x x,      x14 = x7 x x7
x15 = x14 x x,      x30 = x15 x x15,      x31 = x30 x x.
This is not the shortest sequence of multiplications to compute  x31. There are many ways with only seven multiplications. The following is one of them:
x2 = x x x,      x4 = x2 x x2,      x8 = x4 x x4,      x10 = x8 x x2
x20 = x10 x x10,      x30 = x20 x x10,      x31 = x30 x x.
There however is no way to compute  x31 with fewer multiplications. Thus this is one of the most efficient ways to compute  x31 only by multiplications.

If division is also available, we can find a shorter sequence of operations. It is possible to compute x31 with six operations (five multiplications and one division):

x2 = x x x,      x4 = x2 x x2,      x8 = x4 x x4,      x16 = x8 x x8,      x32 = x16 x x16,      x31 = x32 ÷ x.
This is one of the most efficient ways to compute  x31 if a division is as fast as a multiplication.

Your mission is to write a program to find the least number of operations to compute xn by multiplication and division starting with x for the given positive integer n. Products and quotients appearing in the sequence of operations should be x to a positive integer's power. In other words, x-3, for example, should never appear.

Input

The input is a sequence of one or more lines each containing a single integer nn is positive and less than or equal to 1000. The end of the input is indicated by a zero.

Output

Your program should print the least total number of multiplications and divisions required to compute xn starting with x for the integer n. The numbers should be written each in a separate line without any superfluous characters such as leading or trailing spaces.

Sample Input

1
31
70
91
473
512
811
953
0

Sample Output

0
6
8
9
11
9
13
12
题目大意:给出一个数n,求利用x如何在最短的步数内变成x^n,可以利用乘法和除法必须利用已经求出的x的幂指数,而且相除之后不能出现x的负次幂。

解题思路:最直接的想法就是利用dfs进行搜索,但是有一点我们在深搜的时候不知道什么时候是个结尾,因此我们可以利用限定搜索的层数。

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
int limt_dept;
int n,num,vis[1020];
bool dfs()
{
    if(num>limt_dept) return false;
    if(vis[num]==n) return true;
    if(vis[num]<<(limt_dept-num)<n)return false;
    for(int i=0;i<=num;i++)
    {
        num++;
        vis[num]=vis[num-1]+vis[i];
        if(vis[num]<=2000&&dfs())return true;
        vis[num]=vis[num-1]-vis[i];
        if(vis[num]>0&&dfs())return true;
        num--;
    }
    return false;
}
int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        limt_dept=0;
        while(limt_dept<=20)
        {
            num=0;
            vis[num]=1;
            if(dfs())
                break;
            limt_dept++;
        }
        printf("%d\n",limt_dept);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值