UVA-LA 3135 2004年北京站C题 STL priority_queue自定义优先顺序优先队列的使用

https://icpcarchive.ecs.baylor.edu/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1136

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.

Query-1: �Every five minutes, retrieve the maximum temperature over the past five minutes.� Query-2: �Return the average temperature measured on each floor over the past 10 minutes.�

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

For the Argus, we use the following instruction to register a query:

Register Q_num Period

Q_num (0 < Q_num ≤ 3000) is query ID-number, and Period (0 < Period ≤ 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

Input 

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of �#�.

The second part is your task. This part contains only one line, which is one positive integer K (≤ 10000).

Output 

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input 

Register 2004 200
Register 2005 300
#
5

Sample Output 

2004
2005
2004
2004
2005
题目大意:编写一个称为:Argus的系统。该系统支持一个register命令。该命令注册一个触发器,她每period秒钟就会产生一个编号为Q_num的事件。你的任务是模拟出前k个事件。如果有多个事件同时发生,先处理Q_num小的事件。

解题思路:用优先队列维护每个触发器的“下一个事件”,然后每次从中取出最早发生的一个事件重复k次即可,。任意时刻优先队列中都是n个元素,因此总的时间复杂度为O(klogn)。

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <queue>
using namespace std;
struct note
{
    int time,q_time,period;
    //重要!优先级比较函数。优先级高的先出队
    bool operator < (const note & a)const//这里的const必不可少
    {
        return (time>a.time||time==a.time&&q_time>a.q_time);
    }
};
priority_queue <note>  que;
int main()
{
   char a[20];
   while(~scanf("%s",a)&&a[0]!='#')
   {
       note p;
       scanf("%d%d",&p.q_time,&p.period);
       p.time=p.period;//初始化“下一次事件的时间”为它的周期
       que.push(p);
   }
   int m;
   scanf("%d",&m);
   while(m--)
   {
       note r=que.top();//取下一个事件
       que.pop();
       printf("%d\n",r.q_time);
       r.time+=r.period;//更新该触发器下一个事件的时间
       que.push(r);//重新插入优先队列
   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值