2010成都站c题||uvalive5006 二进制

https://icpcarchive.ecs.baylor.edu/index.php?option=com_onlinejudge&Itemid=8&category=381&page=show_problem&problem=3007

For 2 non-negative integers x and y, f(xy) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1, f(0, 3)=2, f(5, 10)=4.

Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in Asuch that f(ab) is minimized. If there are more than one such integers in set A, choose the smallest one.

Input

The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < mn ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.

Output

For each test case you should output n lines, each of which contains the result for each query in a single line.

Sample Input

2
2 5
1
2
1
2
3
4
5
5 2
1000000
9999
1423
3421
0
13245
353

Sample Output

1
2
1
1
1
9999
0
题目大意:对于B中的任意一个数在A中找出一个数,使两个数的二进制位不同的位数最少,输出A中的数。

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
int a[105],b[105],m,n;
int judge(int a,int b)
{
    if(a<b)
        swap(a,b);
    int sum=0;
    while(b)
    {
        int x=a&1;
        int y=b&1;
        if(x!=y)
            sum++;
        a>>=1;
        b>>=1;
    }
    //printf("(%d %d %d)\n",a,b,sum);
    while(a)
    {
        if(a&1)
            sum++;
        a>>=1;
    }
   // printf("%d\n",sum);
    return sum;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<m;i++)
            scanf("%d",&b[i]);
        sort(a,a+n);
        for(int i=0;i<m;i++)
        {
            int minn=0x3f3f3f3f;
            int cnt=0;
            for(int j=0;j<n;j++)
            {
                int ans=judge(b[i],a[j]);
                if(minn>ans)
                {
                    minn=ans;
                    cnt=a[j];
                }
            }
            printf("%d\n",cnt);
        }
    }
    return 0;
}
/*
int main()
{
    int x,y;
    while(~scanf("%d%d",&x,&y))
    {
        int ans=judge(x,y);
    }
    return 0;
}*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值