hdu 4738 双连通图的桥

http://acm.hdu.edu.cn/showproblem.php?pid=4738

Problem Description
Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn't give up. Caocao's army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao's army could easily attack Zhou Yu's troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao's army could be deployed very conveniently among those islands. Zhou Yu couldn't stand with that, so he wanted to destroy some Caocao's bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn't be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.
 

Input
There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N 2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.
 

Output
For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn't succeed any way, print -1 instead.
 

Sample Input
  
  
3 3 1 2 7 2 3 4 3 1 4 3 2 1 2 7 2 3 4 0 0
 

Sample Output
  
  
-1 4


/**
hdu 4738 双连通图的桥
题目大意:已知一个曹操修了m座桥,每座桥上有一定的士兵看守,周瑜现在又一枚炸弹,他想炸掉一座桥,使得曹操的所有桥不能全部相连接,
           并且要想炸桥成功必须使派去炸桥的士兵人数不少于曹操在该桥布置的守军人数。求周瑜要达到目的至少要派多少士兵前去炸桥
解题思路:给出的m座桥连接的n个点正好构成一个无向连通图,我们要做的就是求出这个无向连通如里面权值最小的桥的权值是多少。
           这个题有两个陷阱:
                             1,当桥上的守军为0时,我们要派去的士兵应该是1.而不是0;
                             2,当图根本就不连通的时候我们就不用去炸了,结果为0
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=1005;

int n,m;
int head[maxn],ip;

void init()
{
    memset(head,-1,sizeof(head));
    ip=0;
}

struct note
{
    int v,w,cut,next;
}edge[maxn*maxn*2];

void addedge(int u,int v,int w)
{
    edge[ip].v=v,edge[ip].cut=false,edge[ip].w=w,edge[ip].next=head[u],head[u]=ip++;
}

int dfn[maxn],low[maxn],dex;

void tarjan(int u,int pre)
{
    dfn[u]=low[u]=++dex;
    int pre_num=0;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        int w=edge[i].w;
        if(pre==v&&pre_num==0)
        {
            pre_num++;
            continue;
        }
        if(!dfn[v])
        {
            tarjan(v,u);
            if(low[u]>low[v])low[u]=low[v];
            if(low[v]>dfn[u])
            {
                ///bridge++;
                edge[i].cut=true;
                edge[i^1].cut=true;
            }
        }
        else if(low[u]>dfn[v])
        {
            low[u]=dfn[v];
        }
    }
}

void solve()
{
    memset(dfn,0,sizeof(dfn));
    dex=0;
    int num=0;
    for(int i=1;i<=n;i++)
    {
        if(!dfn[i])
        {
            tarjan(i,i);
            num++;
        }
    }
    if(num>1)///并非连通图
    {
        printf("0\n");
        return;
    }
    int ans=0xfffff;
    for(int u=1;u<=n;u++)
    {
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            if(edge[i].cut)
            {
                ans=min(ans,edge[i].w);
            }
        }
    }
    if(ans==0xfffff)ans=-1;///没有桥
    if(ans==0)ans++;///桥上的守军为0
    printf("%d\n",ans);
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        init();
        for(int i=0;i<m;i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            addedge(u,v,w);
            addedge(v,u,w);
        }
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值