UvaLA 3029 最大子矩阵问题

https://icpcarchive.ecs.baylor.edu/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1030

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees, factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems � he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units. The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N. The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input 

The first line of the input file contains an integer K � determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units, separated by a blank space. The symbols used are:
R � reserved unit
F � free unit
In the end of each area description there is a separating line.

Output 

For each data set in the input file print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input 

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output 

45
0
/**
UvaLA 3029 最大子矩阵问题
题目大意: 给定一个m*n的子矩阵,其中一些格子是空地(F),其他是障碍(R),找出一个全部是由F组成的面积最大的子矩阵,
           输出其面积乘3的结果。
解题思路:
          思路来源:http://wenku.baidu.com/view/56f7342b3169a4517723a3ad.html  算法合集之《浅谈用极大化思想解决最大子矩形问题》国家集训队论文
          我们把每个格子向上延伸的空格看做是一条悬线,并且up(i,j),left(i,j),right(i,j)表示格子(i,j)的悬线长度以及该悬线向左向右的运动极限。这样每个格子(i,j)
          对应着一个以第i行为下边界、高度为up(i,j)左右边界分别为left(i,j),right(i,j)的矩阵。不难发现,所有的这些矩阵中面积最大的就是题目要求的答案。
具体求法:
         当第i行第j列不是空格是,3个数组的值均为0,否则up(i,j)=up(i-1,j)+1那么left和right呢?我们发现:left(i,j)=max{left(i-1,j),lo+1}其中lo是第i行中,第
         j列的左边的最接近障碍格的编号。如果从左到右计算left(i,j).则很容易维护lo。right的计算也同理,但要从右往左计算,因为要维护第j列右边最近的障碍格的
         列编号ro。
*/
#include <stdio.h>
#include <algorithm>
using namespace std;
const int maxn=1005;
int mat[maxn][maxn],up[maxn][maxn],left[maxn][maxn],right[maxn][maxn];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d%d",&m,&n);
        for(int i=0; i<m; i++)
        {
            for(int j=0; j<n; j++)
            {
                int ch=getchar();
                while(ch!='F'&&ch!='R')
                    ch=getchar();
                mat[i][j]=ch=='F'?0:1;
            }
        }
        int ans=0;
        for(int i=0; i<m; i++)//从上到下逐行处理
        {
            int lo=-1,ro=n;
            for(int j=0; j<n; j++)//从左到右扫描,维护up和left
            {
                if(mat[i][j]==1)
                {
                    up[i][j]=left[i][j]=0;
                    lo=j;
                }
                else
                {
                    up[i][j]=i==0?1:up[i-1][j]+1;
                    left[i][j]=i==0?lo+1:max(left[i-1][j],lo+1);
                }
            }
            for(int j=n-1; j>=0; j--)//从右往左扫描,维护right并更新答案
            {
                if(mat[i][j]==1)
                {
                    right[i][j]=n;
                    ro=j;
                }
                else
                {
                    right[i][j]=i==0?ro-1:min(right[i-1][j],ro-1);
                    ans=max(ans,up[i][j]*(right[i][j]-left[i][j]+1));
                }
            }
        }
        printf("%d\n",ans*3);
    }
    return 0;
}

附解题思路的图:

                                   

                                                                         

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值