hdu2444 二分图的匹配,先判断是否为二分图

http://acm.hdu.edu.cn/showproblem.php?pid=2444

Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 

Sample Input
  
  
4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
 

Sample Output
  
  
No 3
 

Source

/**
hdu2444 二分图的匹配,先判断是否为二分图
题目大意:给定一个图,判断是否为二分图如果是请求出最大匹配数
解题思路:对于是不是二分图:所有的点可以分到两部分,每一部分的点之间没有联系,我们可以用dfs搜索就知道了。
           至于二分图的匹配要用到匈牙利算法
*/
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <iostream>
using namespace std;
const int maxn=202;

vector <int>vec[maxn];
int linker[maxn];
bool used[maxn];
int n,m;
int matchs[maxn],cnt[maxn];

bool dfs(int u)
{
    for(int i=0;i<vec[u].size();i++)
    {
        int v=vec[u][i];
        if(!used[v])
        {
            used[v]=true;
            if(linker[v]==-1||dfs(linker[v]))
            {
                linker[v]=u;
                return true;
            }
        }
    }
    return false;
}

int hungary()
{
    int res=0;
    int u;
    memset(linker,-1,sizeof(linker));
    for(int u=1;u<=n;u++)
    {
        memset(used,false,sizeof(used));
        if(dfs(u))
            res++;
    }
    return res;
}

bool judge(int x,int y)
{
    int i;
    for(int i=0;i<vec[x].size();i++)
    {
        if(cnt[vec[x][i]]==0)
        {
            cnt[vec[x][i]]=y^1;
            matchs[vec[x][i]]=true;
            if(!judge(vec[x][i],y^1))return false;
        }
        else if(cnt[vec[x][i]]==y)
            return false;
    }
    return true;
}

bool matched()///判断是否为二分图
{
    memset(matchs,false,sizeof(matchs));
    for(int i=1;i<=n;i++)
    {
        if(vec[i].size()&&!matchs[i])
        {
            memset(cnt,0,sizeof(cnt));
            cnt[i]=1;
            matchs[i]=true;
            if(!judge(i,1))
                return false;
        }
    }
    return true;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
        {
            if(vec[i].size())
                vec[i].clear();
        }
        while(m--)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            vec[u].push_back(v);
            vec[v].push_back(u);
        }
        if(matched())
            printf("%d\n",hungary()/2);
        else
            printf("No\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值