hdu 4274 树形dp

25 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=4274

Problem Description
I'm a manager of a large trading company, called ACM, and responsible for the market research. Recently, another trading company, called ICPC, is set up suddenly. It's obvious that we are the competitor to each other now!
To get some information about ICPC, I have learned a lot about it. ICPC has N staffs now (numbered from 1 to N, and boss is 1), and anybody has at most one superior. To increase the efficiency of the whole company, the company contains N departments and the ith department is led by the ith staff. All subordinates of the ith staff are also belong to the ith department.
Last week, we hire a spy stealing into ICPC to get some information about salaries of staffs. Not getting the detail about each one, the spy only gets some information about some departments: the sum of the salaries of staff s working for the ith department is less than (more than or equal to) w. Although the some inaccurate information, we can also get some important intelligence from it.
Now I only concerned about whether the spy is telling a lie to us, that is to say, there will be some conflicts in the information. So I invite you, the talented programmer, to help me check the correction of the information. Pay attention, my dear friend, each staff of ICPC will always get a salary even if it just 1 dollar!
 

Input
There are multiple test cases.
The first line is an integer N. (1 <= N <= 10,000)
Each line i from 2 to N lines contains an integer x indicating the xth staff is the ith staff's superior(x<i).
The next line contains an integer M indicating the number of information from spy. (1 <= M <= 10,000)
The next M lines have the form like (x < (> or =) w), indicating the sum of the xth department is less than(more than or equal to) w (1 <= w <=100,000,000)
 

Output
For each test case, output "True" if the information has no confliction; otherwise output "Lie".
 

Sample Input
  
  
5 1 1 3 3 3 1 < 6 3 = 4 2 = 2 5 1 1 3 3 3 1 > 5 3 = 4 2 = 2
 

Sample Output
  
  
Lie True
/**
hdu  4274 树形dp
题目大意:一棵树,其部分节点给出一些不等关系,并且每个节点的值至少为1,祖先节点的总值必须大于该子树下值的总和。
解题思路:一开始想错了,例如代码后给出的第一例子是对的,我们只是保证子树的和不要超过祖先的最小限制就可以了。
          对于没个节点维护一个最小值和一个最大值,初始化最小值为1,最大值为-1,没更新完一个节点比较最小值是否超过了
          最大值就可以了。值得一提的是,输入可能就有矛盾的,因此在dfs一个节点的子树之前,要先进行判断。
*/
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <string.h>
using namespace std;
const int maxn=10005;

int head[maxn],ip;
bool judge;
int n,up[maxn],down[maxn];

void init()
{
    memset(head,-1,sizeof(head));
    ip=0;
}

struct note
{
    int v,next;
}edge[maxn*2];

void addedge(int u,int v)
{
    edge[ip].v=v,edge[ip].next=head[u],head[u]=ip++;
}

void dfs(int u,int pre)
{
     if(up[u]!=-1&&down[u]>up[u])
     {
          judge=false;
          return;
     }
    bool flag=0;
    int ans=0;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(pre==v)continue;
        flag=1;
        dfs(v,u);
        ans+=down[v];
    }
    if(flag)
    {
       down[u]=max(down[u],ans+1);
       if(up[u]!=-1&&down[u]>up[u])
           judge=false;
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        init();
        for(int i=2; i<=n; i++)
        {
            int v;
            scanf("%d",&v);
            addedge(i,v);
            addedge(v,i);
        }
        for(int i=1;i<=n;i++)
        {
            up[i]=-1;
            down[i]=1;
        }
        int m;
        scanf("%d",&m);
        while(m--)
        {
            int a,b;
            char s[3];
            scanf("%d%s%d",&a,s,&b);
            if(s[0]=='<')
            {
                up[a]=b-1;
            }
            else if(s[0]=='>')
            {
                down[a]=b+1;
            }
            else
            {
                up[a]=down[a]=b;
            }
        }
        judge=true;
        dfs(1,-1);
        if(judge)
            puts("True");
        else
            puts("Lie");
    }
    return 0;
}

/**
5
1
1
3
3
3
4 < 3
3 = 5
5 < 3

5
1
1
3
3
3
1 > 5
3 = 4
2 = 2
**/


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值