hdu4649 概率dp

17 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=4649

Problem Description
Timer took the Probability and Mathematical Statistics course in the 2012, But his bad attendance angered Professor Tian who is in charge of the course. Therefore, Professor Tian decided to let Timer face a hard probability problem, and announced that if he fail to slove the problem there would be no way for Timer to pass the final exam. 
As a result , Timer passed. 
Now, you, the bad guy, also angered the Professor Tian when September Ends. You have to faced the problem too. The problem comes that there is an expression and you should calculate the excepted value of it. And the operators it may contains are '&' (and),'|'(or) and '^'(xor) which are all bit operators. For example: 7&3=3, 5&2=0, 2|5=7, 4|10=14, 6^5=3, 3^4=7.
Professor Tian declares that each operator O i with its coming number A i+1 may disappear, and the probability that it happens is P i (0<i<=n). 
 

Input
The input contains several test cases. For each test case, there is a integer n (0<n<=200) in the first line.In the second line, there are n+1 integers, stand for {A i}. The next line contains n operators ,stand for {O i}. The forth line contains {P i}. 
A i will be less than 2 20, 0<=P i<=1.
 

Output
For each text case, you should print the number of text case in the first line.Then output the excepted value of the expression, round to 6 decimal places.
 

Sample Input
  
  
2 1 2 3 ^ ^ 0.1 0.2 2 8 9 10 ^ ^ 0.5 0.78 1 1 2 & 0.5
 

Sample Output
  
  
Case 1: 0.720000 Case 2: 4.940000 Case 3: 0.500000

/**
hdu4649 概率dp
题目大意:给定一个位运算服连接的表达式,第i个运算符与其后面的数字共同出现和消失,其消失的概率的为pi,问该表达式最后的期望值为多少
解题思路:由于为运算没有进位的影响,用dp[i][j][0~1]表示前j个数第i位0或1的期望为多少,那么最后dp[i][n][1]*(1<<i)加入最终结果就好了,
           状态转移方程详见代码
*/
#include <string.h>
#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
int n,a[1003];
double dp[25][500][2],p[500];
char s[1003][2];
int main()
{
    int tt=0;
    while(~scanf("%d",&n))
    {
        for(int i=0; i<=n; i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=1; i<=n; i++)
        {
            scanf("%s",s[i]);
        }
        for(int i=1; i<=n; i++)
        {
            scanf("%lf",&p[i]);
        }
        double ans=0;
        memset(dp,0,sizeof(dp));
        for(int i=0; i<=20; i++)
        {
            if(a[0]&(1<<i))dp[i][0][1]=1;
            else dp[i][0][0]=1;
            for(int j=1; j<=n; j++)
            {
                ///第j个符号以及其后面的数字不考虑
                dp[i][j][0]+=dp[i][j-1][0]*p[j];
                dp[i][j][1]+=dp[i][j-1][1]*p[j];
                ///第j个符号以及其后面的数字不考虑
                if(a[j]&(1<<i))///第j个数的第i位为1
                {
                    if(s[j][0]=='&')
                    {
                        dp[i][j][1]+=dp[i][j-1][1]*(1-p[j]);
                        dp[i][j][0]+=dp[i][j-1][0]*(1-p[j]);
                    }
                    else if(s[j][0]=='|')
                    {
                        dp[i][j][1]+=dp[i][j-1][0]*(1-p[j]);
                        dp[i][j][1]+=dp[i][j-1][1]*(1-p[j]);
                    }
                    else
                    {
                        dp[i][j][1]+=dp[i][j-1][0]*(1-p[j]);
                        dp[i][j][0]+=dp[i][j-1][1]*(1-p[j]);
                    }
                }
                else///第j个数的第i位为0
                {
                    if(s[j][0]=='&')
                    {
                        dp[i][j][0]+=dp[i][j-1][1]*(1-p[j]);
                        dp[i][j][0]+=dp[i][j-1][0]*(1-p[j]);
                    }
                    else if(s[j][0]=='|')
                    {
                        dp[i][j][0]+=dp[i][j-1][0]*(1-p[j]);
                        dp[i][j][1]+=dp[i][j-1][1]*(1-p[j]);
                    }
                    else
                    {
                        dp[i][j][0]+=dp[i][j-1][0]*(1-p[j]);
                        dp[i][j][1]+=dp[i][j-1][1]*(1-p[j]);
                    }
                }
            }
            ans+=(1<<i)*dp[i][n][1];
        }
        printf("Case %d:\n%.6lf\n",++tt,ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值