hdu Least Common Multiple

Least Common Multiple

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 31   Accepted Submission(s) : 14
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output

105
10296

Source

East Central North America 2003, Practice
此题大意:求所给数的最小公倍数。
思路:先两两相求,最后得结果。我是先求两个数的最大公约数再用两数之积去除最大公约数。求最大公约有多种方法,我用的辗转相除法,即两数相除,小的做除数大的为被除数求余数,若余数不为零,让原来的除数做被除数,余数做除数相除求余数,一直做下去知道余数为零,此时的得除数便是两个数的最大公约数。
代码:
#include <iostream>
using namespace std;
//定义一个求最大公约数的函数
//辗转相除求最大公约数
int gcd(long long int a,long long int b)
{
    long long int r,t;
    if(a<b)//保证a为最大的数
    {
        t=a;
        a=b;
        b=t;
    }
    while((r=(a%b))!=0)//直至余数为零
    {
        a=b;
        b=r;
    }
    return b;//返回除数数
}
int main()
{
    long long int i,j,s,m,n,k;
    cin>>n;
    for(i=0;i<n;i++)
    {
        cin>>m;
        cin>>k;
        s=k;
        //两个两个的求
        for(j=1;j<m;j++)
        {
           cin>>k;
           s=(s*k)/gcd(s,k);//最小公倍数为两个数之积除以最大公约数
        }
        cout<<s<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值